YLXD50YL (2.0.6_0025) Home Assistant Unavaliability

Hi! after updating the firmware on the YLXD50YL lamp to 2.0.6_0025, problems started in the assistant’s house: when turned on, the lamp appears in the app, but after a while (from a few minutes to 4-5 hours) it falls off. The following entry appears in the Home Assistant logs:
ERROR (SyncWorker_32) [homeassistant.components.yeelight] Unable to update device 192.168.XX.XX, [name]: Bulb closed the connection…

After the lamp is physically turned off and turned on, they are available again in the Home Assistant for a while/

Sometimes the lamps fall off synchronously, sometimes in turn - I didn’t find any connection. At the same time, in the Yeelight app, the lamps are accessible and controlled.

This problem is observed on all 4 YLXD50YL lamps used by me after updating the firmware on the YLXD50YL lamp to 2.0.6_0025.

Please help with the solution. Thanks!

Can you please share with us the way that you are using to integrate this lamps on your home assistant ?

The lamps are connected via standard integration Yeelight
2020-10-08_11-51-44
2020-10-08_11-48-44

Hi again!
Please tell me if there is any hope for a solution to my problem?
In the next topic, the same problem is observed on many devices: https://forum.yeelight.com/t/topic/12894/297.
Is it possible to downgrade the firmware to the previous version 2.0.5_XX?
So far, I have made a crutch in automation that turns off/on the Aqara switch, but the lighting disappears for 20-30 seconds while the lamp is reconnected. This is very irritating :confounded:.
If there is anything I can do to help with the diagnosis, please write to me.

I have same problem with lamps ylxd50yl:

I have two lamps yeelight ylxd50yl, after upgrading the firmware to 2.0.6.0025 the devices don’t work properly.
The control is lost some time after switching on — the lamp is not found in mi home app and yeelight.
The control is lost with bluetooth dimmer and remote control as well as with aqara wall wireless switch.
The lamps work fine on homekit protocol.

The other yeelight Meteorite lamp continues working normally from both apps and remotes.
The network configuration is based on the mikrotik router. The lamps are located not far from the router.
The ping response time of the devices is within normal range 3-50ms, the same is with yeelight Meteorite lamp.
The Yeelight Meteorite lamp has 2.0.6.0049 firmware.

Can you add me to the whitelist as well, MI ID: 1742326755

Seems I have the same problem, as many others who updated to v2.0.6.0025. The firmware is total shit. After the update my lamps stopped working with Home assistant, disappears after several hours after reboot from Xiaomi App, even don’t react on Yeelignt dimmers! Hey, developers from Yeelight - why do you release so shitty update, which is much more unstable than previous? By the way, previous one was unstable too. Do you have QA as a part of development process? Do you have testers in your team? What to expect from next so called “release?” I think it will be the problem just to switch the lamps on by usual wall switch.

Have same issue on YLXD49YL. More info on problem: YLXD49YL LAN Control stop working after firmware update to 2.0.6_0024
It’s seems LAN Control protocol broken on some firmware versions.

I wonder if anyone from Yeelight reads this forum? A week has passed and there is no response from them…

I’m found a temporary solution, disable lan control completely and use the Homekit Protocol with homeassistant. As a result, no more lamps are lost in HA, 3 days without switching off power. Worked both in the app mi home and yeelight and from bluetooth remotes.

HomeKit can work without cloud (Internet connection)?

Yes, it worked without internet connection, HomeKit and Yeelight integrations in HA.

@CrOFF2020 Thanks! Connect via HomeKit Controller, but this integration weak and can’t control Night mode and Ambilight.
UPD: Night mode can be emulated via settings. Disabling LAN Control Protocol in my case not needed.

@Zuz666 And what about Ambilight?

same issue here, on the larger 49YL previous firmware (.20) was having issues too but this new one (2.0.6_0024) is completely broken, both in yeelight own app & with homebridge (yeelight-wifi plugin).

Yeelight, please TEST your updates before sending them to production, seriously…

If this does not resolve in the near-future I will have to fukken rewrite the firmware (if the damn thing is an esp32 like in some others & not erase-locked) or even replace the mcu with another one -_- … will open source it if it comes to that.

Sad thing with yeelights is that the hw & leds specs are top-spec but the sw is more than sub-par :frowning:

1 Like

I have the same problem with yeelight bulb 1s and bside lamp 2.
After udpate firmware problem with lan mode…
Work a few hours after… close.

Now a have put in the paperbasket the 1s lamp… i think bside the same.
Thanks Xiaomi

you might want to try with the only thing that works reliably which are the BLE remotes & dimmer wall/wireless switches…

I solved it by changing the yeelight 1s for now … with other brands.
I will do the same with the bside.
Unfortunately no one answers us or makes us do the downgrade or upgrade, :wink:
many thanks

Same here.

3 bulbs unresponsible after 90 minutes approx from energized through the home assistant app. They still work trough the yeelight app.

Before the firmware update, they were working ok.

ID: 6339942887