Can't connect to Router

I still would like to get this resolved.

I have the very same issue with my ceiling light. Unfortunately the same things are constantly said check DNS, check password is correct. This is all stated as you have done but then Yeelight staff no longer reply back.

@kyleluna @Robbie

First of all, please check if the bulb connected to your router, you can check it form DHCP list.

As I have said before, It does not appear on my DHCP list. Also my wifi is on 2.4GHz with a WPA2-Personal.

Same here. It does not connect.

Might be related, i tried to connect ceiling light 650 to application - and experiened connection timeout (tried atleast 10 times).

I did following: logged in on some existing account (see my link for login/pw), paired the lamp there, update firmware. And after that i was able to register it under my own account.

Check the first post:

@crymo99
The lamp need connect to router, then bind the lamp to your account. The issue we encounter is the first step :sob:

@kyleluna @Robbie

I am not sure why the lamp can’t connect to your router, does the lamp in black list or is there some filter with your router?

I think I found out the problem. It took me a while, but the lamp (my white 1 version) does not connect properly to a wifi-connection greater than 2.4 GHz. You should connect your lamp to your 2.4 GHz network

i think this is why its cheaper than the philips hue !!

the pairing will never work with me !

unfortunately i bought 2 of these , and no one worked as advertised ! its just a regular light with nothing smart !

i hop that you fix this soon because i am now so mad !

1 Like

This is a wifi based device, it is different with hue that it is based on zigbee.

  1. pease have a check if the bulb connect to your router.
  2. If yes, try change DNS of your router to 8.8.8.8 and connect again.

What if ISP doesn’t allow me to change the dns server?

Which server do you select?

Try connect your ISP for help, why they block the domain of xiaomi cloud (ot.io.mi.com).

ot.io.mi.com is responding okay to my computer but the bulb is not responding and failing to connect.

Pinging ot.io.mi.com [120.92.65.242] with 32 bytes of data:
Reply from 120.92.65.242: bytes=32 time=332ms TTL=39
Reply from 120.92.65.242: bytes=32 time=330ms TTL=39
Reply from 120.92.65.242: bytes=32 time=324ms TTL=39
Reply from 120.92.65.242: bytes=32 time=326ms TTL=39

Ping statistics for 120.92.65.242:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 324ms, Maximum = 332ms, Average = 328ms

ot.io.mi.com is domain of Mainland China server, so could you have a try with china server?

May i know whats is the router setting to connect the bulb

Can you update my firmware with betta version? My ID 2694649566

Its solved thanks. I change my device and its work

Hi! Can you update my firmware with betta version? My ID : 6350795047

Is the router problem solved? I can’t connect to asus rt N19 router? connecting to asus n16 modem

This problem solved? I have same problem here. I have removed the device from the app. then i wanted to reconnect it, but it stopped at loading 25% and never reconnected. Please staff, help us.