Can't Link Yeelight Actions to Google Home


Hi there, can you check my ID - 1725586129 - same problem, several attemps, but the device yeelight bedside lamp wont appear on google list, same as all above


Hi partner, bedside lamp version 1 is bluetooth device, it doesn’t support GoogleHome.


I also can’t associate my 2 Yeelights with Google Home. My id is 1762282719 and I’ve been trying for several days. All I see is that it has been linked successfully, but no devices are available.


Hi partner, i recorded your MI ID, please try re-link xiaomi account, i will see your access log.


Thank you - I just tried again but it still didn’t work. Do the logs help?


I found your sync log and simulated your data, it is normal on my mobile phone. can your provide a video ?


Thanks for looking. Here is a screen recording of the issue. As you can see, “assign rooms” page loads and then exits, and then no devices appear.


This issue should be a Google Home’s bug, i mailed to GoogleHome support team, i will let you know when i get a reply from them.


I have same issue with this guy, can’t connect to goole home.
my id 1548183532 and i choose Singapore server.

Please help.

best regards,



Google got in touch with me. The fix was to rename my devices in the Yeelight app. It’s working now.


Hi Arman,

I found your color bulb is offline, please keep it online and try connect to GoogleHome.

Kind Regards,


I have same problem here, Please help. RGB Light, server germany my ID is 1809303082.
Trying to link the yeelight to google home brings me to the xiaomi - account page, when trying to sign in / get permissions - I get a message in google home: Setting could not be saved…
Thank you

update: I got it: deleted the account link in Mi Account, used another divice and it works!


Hi my mi id is 1645309511, linked to Google home without issue but there is no device.

Previously set up ok but after the yeelight Android app update, I reset and relinked all devices in the app.

Now I need some help to set up properly to enable Google home voice commands.




What’s your devices type? could you paste a screenshot on this?


I am using the desk light and bedside light


I found your MI ID is “1645309680”, please use “1645309680” to link GoogleHome.


Hello, I have transferred my two RGB 1st GEN lamps from Singapore to Germany but I am not able to control the two lights with my Google Home. It says “Living Room Light not available”. I live in Italy but this feature should be available in my country so I can’t understand what I am doing wrong


Try to reconnect your mi-account in the google home app.


I have tried it but Google Home keeps saying “Living Room Light not available at the moment”. What can I do more? I have already reset my bulbs but nothing changes


Could you tell me your MI ID?