Can't Link Yeelight Actions to Google Home


I have been unlinking and relinking Yeelight to update changes that I have made on Yeelight to Google Home. I have done this many times and it works fine until last night when I tried to relink, it say successful but nothing has been transferred across to Google Home and Yeelight Actions remains as a device that I can add despite how many times I have tried. I have tried this on different phones as well, no luck. I have 2 colour and 2 white bulbs. My MI ID is 326393627.


OK, I recorded it.


For some reason, the issue fixed itself last night but I had to keep trying at least 7 times to get it. At this point I don’t dare to try unlinking Yeelight Actions from Home


I can’t see my Yeelight on Google Home at all. I’ve tried this many times: From Google Home, Home Control, add Yeelight Actions. This opens a browser to sign in Yeelight with Mi Account and says " Linking your Yeelight Actions to Google Home." It then completes but no device is added. My device is visible from the Yeelight Android App.


Which server does your device connect to?


Hi admin, I’m connected to singapore server. However, i suffered from the issue of adding yeelight action into google home, it will disappear after showing successfully added. My mi ID is :1586645515 and i’m using Mi Max 2.


Hi jiewei,
I log your id, you can link yeelight with google home.


I don’t find your device, can you provide a screenshot on yeelight app?


hi yusure, suddenly i was able to add devices in. thanks


Team, I’m having issues adding my Yeelight to google home too. No error, everything goes through but doesn’t add. 1747973536


@yusure Even I am having issues while trying to add the colored LED bulb to google home. The entire process goes through and it also gives a message that successfully linked the yeelight actions but no bulb ever shows up. Initially the bulb was connected to US server. I deleted the bulb, changed the server to Singapore and added it again. But still the same thing.
My MI ID: 1763436378
Please help


I’ve already recorded it, please try link it on Google Home app.


@yusure it still not getting detected. I also did a factory reset just now and then tried to add it again. No luck.
Using the Singapore server.


I didn’t found your request log, how many your xiaomi ID? Did you use any other ID on Google Home app?


I also can’t add. ID 1765501233


I found you connected to the China server, however Google Home not supported China server, please connect to Singapore or US server!


I’m connected to the Singapore server from Australia. The bulb is a colour bulb, not a bedside lamp


Please tell me your xiaomi ID


Team, I’m having issues adding my Yeelight to google home too. No error, everything goes through but doesn’t add. … my id is 1754055145

I tried both United States and Singapore servers. The yeelight app works fine… Just can’t integrate with Google home


I am also having issue connecting my Yeelight to google home as well…

I am using mainland china server and my id is 1643544091

if I switch to SG server or US server, I only left with 2 devices… which are original bedside lamp … but even those two does not show up in google home, I guess it is because they are bluetooth only device?