Google Home -> Yeelight Routine/ Scenes Bug

Bug: Google fails to sync new Yeelight devices/ scenes + Google Home won’t operate any Yeelight Scenes

Notes: Google Home will still turn Yeelights on and off, change the colour and brightness level - it’s just scenes. Scenes work and operate still from the Yeelight app also. Nanoleaf, Smartlight etc. all still work as expected so seems isolated to Yeelight.

This started happening for the first time around a week ago.

I have tried de-linking the account and re-connecting, and tried on my other Google account - same issue.

Affecting all my lights (around 13 devices) so looks like the issue isn’t related to any specific one (I have lightstrips, ceiling light, bulbs etc.)

Happy to provide staff with any account details needed to repro this.

Seems related to Scene not working with Google Home in someway but issue was confirmed to be resolved there, hence opening this thread.

Thanks very much.

Tagging @niuxinghua if you could please take a look this would be appreciated. MI ID: 1700442015

Is there any update here please?

@yusure @niuxinghua this still isn’t working, any help appreciated

still working,any result we will get you noticed

Thanks a mil :slight_smile: If there is anything I can provide to help do let me know.

@niuxinghua 6417973038 is my other account which is also affected by this on 2 lights just in case it helps. Have opted out of preview programme for Google Home also.

hello does the problem still exsit?

It still exists unfortunately. I have just tried creating another scene on 1700442015, syncing devices but nothing shows etc. on Google Home @niuxinghua

it is designed so by google home try call by voice such as call ‘active [scenename]’

@niuxinghua The scenes don’t show up/ have the ability to activate in Google Home.

e.g. I created the new Scene called ‘Test123’.
I sync’d between Google and Yeelight.
Nothing shows on Google Home in the scene section (under routines) i.e. the Test123 scene does not show at all.
Therefore when attempting to say ‘Hey Google, activate Test123’ it doesn’t recognise it at all. Same for every other scene.

However, when I sync my Nanoleaf devices and add new scenes etc. everything works as expected - hence me thinking this is on Yeelights side.

1 Like

try again . it is fixed

@niuxinghua It works. Thank you so so so so so much! Really appreciated.

Same issue for me, despite several reconnection tries, Google Assistant doesn’t show routines anymore.
My id is 6320615509, can you help with it ?

niuxinghua my scenes stopped working as well. my mi id is 120407101

Hi there. My yeelight scenes also stopped working from my Google Home. They all worked for a good 12 months and then stoped working. My id is 1665887927.

Could you please have a look. I. Am connected to the Oregon server.