Cant add lightstrip plus to homekit

I am using iphone 11 ios 13.1 mi home app.
when i try to add lightstrip to homekit, there is no respond. screenshot as below. can see homekit icon but when i click it, it acts like “cancel” button, and back to as if i didnt select the lightstripimage image

1 Like

Have you updated to the latest firmware?

yes,
2.0.6_0063

Could you try Yeelight app?

failed too. screenshot as below

Please go to Home app to create one Home firstly.

I already added home.
I tried to add using ipad to add lightstrip to home.
Screenshot as below.
It seems unable to detect the lightstrip.

2 Likes

Same issue! Can’t find any solution.

1 Like

Has anyone managed to get a solution to this problem? Having the same issue

2 Likes

Same here, I bought 3 lightstrip plus, 2 were added without problema, in one happen this symptom, to add manualy I need the id, where can I get it?

Same here


Why is not working. Please help!!!

1 Like

Hello,

I have the same issue today.
After jumping from yeelight app to home app, the Home app request the HomeKit code.
It shouldn’t request the code, because no code on lightstrip plus.
Everything is the last update. Firmware, iOS, Yeelight app.
MiHome app also doesn’t allow to add.
Please help.

imagem

Thank you
Sérgio

1 Like

I wonder if somebody from yeelight is reading this topics…

I managed to get it working.
I bought 4 Yeelight light strip plus. 2 worked ok and integrated with HomeKit immediately from Mi Home App and Yeelight app.
2 of them would not connect from either Mi home or Yeelight.
So this is what I did:

  1. On Mi Home app changed my server location from Chinese mainland to one in Europe.
  2. Added the strips to this new empty home.
  3. Removed the recently added strips
  4. Changed back to Chinese mainland server
  5. Added the light strips
  6. And then followed the usual process: from Mi Home or Yeelight app
  7. It worked.

Let me know if it works for you.

It doesn’t work for me. Since I am on a European server by default (I live in Belgium), I tried it in reverse by switching to a chinese server and back, but still nothing. I can see the Homekit button, but when i press it, nothin happens.

Having the same issue here. I’ve tried with mi home app and yeelight and none works.

In the mi home app, when I click HomeKit button nothing happens.

Any idea how to solve this?

Same problem, I tried all the servers and without success, I have 2 strips, the first strip without problem and the second I can’t add to HomeKit… I have firmware version 2.0.6_0073. Has anyone succeeded?

Here is my screen record how I try to add a strip to an Apple Homekit…

Hi BartMuyns, have you solved the issue? Same happens for me and I don’t know if I should return the product or not.

I have the exact same issue, even using the Yeelight app doesn’t work, it jumps to the camera / barcode scanner for HomeKit.

I have already tried to change regions, etc. and it still doesn’t work. I am based in Asia. And yes, I have the latest firmware and software updates. Any help will be much appreciated! I’m deciding to fully fit my house with Yeelight, but cannot commit with such issues.