Problems with setting up Google Assistant


#41

Check this:


#42

That’s been sorted now by the look of it. I still can’t connect Yeelight Actions to Google Assistant.


#43

Hoping that sharing more info about my setup, which works, might be useful: I’m using the official Yeelight app and have 3rd party development enabled and connected to Singapore. I also have LAN control enabled.

Once that was up and running, I connected it to the other stuff.


#44

Hi,
thanks for trying. I also have the Yeelight app and I did change those settings that you suggested - they seemed pretty good ideas to me - but no luck, still the same unsuccessful connection, Google Assistant can’t link with Yeelight actions.


#45

i will add to this thread as also having the exact same issue. have tried with Mi accounts for both Singapore server and also mainland china and the message is the same.


#46

I don’t even get that Message. I just end up on the page, where i can select the yeelight actions service.

But i think i will not waste any more time with this issue. I just ordered an Echo Dot. Alexa has no problems with Yeelight.
(tried it with Alexa on my fireTV, I can use the FireTV remote to send voice commands to Alexa and it works like it should.)
Bonus is, that I don’t have to activate the screen on my smartphone (Note 3 with Android 7.1.2) but to say “Alexa” anywhere in my flat.

So Google Assistant will be replaced by Alexa. I will set up my Xiaomi Home automation to work with it, when the Singapore Server will get those features.


#47

Hello, I’ve red the topic.
I didn’t have any problem during these days, Yeelight actions were working just fine with Google Home.
The problem now is that today I’ve got my Desk Lamp, linked it with Yeelight, tried to control it through Yeelight app and everything work just fine, but if I go on Google home, the lamp doesn’t appear on the list in Yeelight actions.
How can I make it appear on Google home and control it through Google assistant?
I repeat, in Yeelight app everything works pretty well and in Google home as well, beside the new lamp that doesn’t appear making impossibile to control it with Google assistant.
Thank you in advance


#48

hello, i have the same problem. is your phone (tab…) under android 6.Xx ?
Mine is under android 5.0 and i think this is the reason


#49

I have Lineage OS 14.1 installed on my Samsung Galaxxy Note 3.

It is running Android 7.1.2.


#50

To everyone who have been suffering Yeelight actions outage:

We are very sorry about this issue. We have checked everything on our side, everything looks normal.

And google has confirmed it was their bug and they were working on it.

But unfortunately, there was no update in the passing four days.

We totally understand how badly you feel and we feel exactly the same way.

We will push google harder to provide some update of this case, at least some root cause analysis.

Please watch following thread to get the latest update.

Sincerely!
-Yeelight


#51

Account link was broken. Google team has been working on it.

Once this case got resolved, we will look into the case you mentioned.

Stay tuned!


#52

Thank you. For now I’m using ifttt as workaround.


#53

i unlinked yeelight actions from google assistant because i couldnt activate scenes and now when i try to re-link it it says “couldn’t update the setting, check internet connection”. Of course i am using them now with IFTTT but its wayyy laggy! Those folks in google are very slow and it annoys me a lot. When its gonna be fixed?


#54

We are pushing them, no result yet, I think they are enjoying their weekend right now.


#55

Hi guys !
It suddenly works for me !
I decided to try again tonight, and I didn’t even have to link google assistant to yeelight actions one more time, it was already done ! (I saw my yeelight color bulb already added in my devices - the result of so many times trying last weekend ??).

Anyway, I set off my ifttt settings to check what google assistant was capable of on its own, and it responds perfectly to my French commands (it even understands changing the color etc…).

I thought I should tell you so as to try again from you smartphones. Good luck !


#56

I tried it yesterday, with no effort.

I am leaving this as it is, Alexa works perfectly for me.


#57

We have fixed the problem. Please refer to: http://forum.yeelight.com/t/about-recent-google-home-issue/1958/6


#58

Tried it just a few minutes ago. Again, it did not work for me. I can log in into my mi account and select to give the permissions, but in Google Assistant setup it shows no devices.
(Lineage OS 14.1 (Android 7.1.2.) on Samsung Galaxy Note 3)

But as I said: it’s ok for me, I use my Echo Dot to control my Yeelight. Works like a charm.

No need for me to follow this Google issue any further.
I would have to activate the screen of my smartphone, then ask “ok google, turn on…”
Now i just have to say “Alexa, turn on…”, without having my smartphone at hand. Much easier and more convenient to handle. :thumbsup:


#59

Hai coasterli;
my yeelight cannot connect to google assistant, instead I’ve already use singapore server and also I connected to IFTT. But no any respond from my google voice control.
The result of google voice control direct me to another page web.
Please, need your assistant. Thanks


#60

Hai Thorsvind,
I saw the link video youtube you share, that the yeelight device has own wifi name “yeelink-light-lamp1_xxxx” because my yeelight doesnt show the wifi name.
Is your yeelight has also shown the wifi name? if yes, do you know how to set up so the yeelight has own wifi. Thanks