Problems with setting up Google Assistant


#21

I already mentioned I’m connected to the Singapore server, and I have this problem.

Are you testing it? Does it work for you? Or do you have the same problems we’re experiencing?


#22

@vevola

We have tested the same case, can’t reproduce that issue.

Are you facing exactly same issue as the screen capture @StePo71 attached?

Which page did it end up after you click the confirm button?


#23

@StePo71 what browser are you using? Are you using Chrome as your default? Did you change server to Singapore?


#24

I was able to identify the problem: It only works if Chrome is set as your default browser because of the google assistant intent. Other browsers won’t work.

I would still invite you to fix the problem with the wrong language showing up, and maybe add a notice that Chrome must be set as default browser.


#25

As you have mentioned, only Yeelight not in the language you expect, right?


#26

See screenshot. The text “Yeelight ga Mi…” is not localized.


#27

Please tell me exactly, which words are incorrect.


#28

That whole line. Everything in your image.


#29

Now you make me confused. According to your previous message, OTHER STUFF is in Portuguese, THE LANGUAGE YOU EXPECT.

What language do you expect? What language do you select in system setting?


#30

Yes, the text of the lower part of the screen - so everything EXCEPT the text from your screenshot - is properly localized. I see it in Portuguese, which is what my device’s localized region.

The “Yeelight ga Mi” text, in other words, all the text from the last screenshot you sent, is NOT properly localized. For some reason it’s in Uzbek (according to Google translate, but I don’t know that language). I would expect it also to be in Portuguese following my device’s localized region.

I’m sorry, but I don’t know how to explain this better…


#31

Got your point now. Will find someone fix it and let you know.


#32

I use Chrome as default (sole) browser on my mobile phone.

I did not find time to change the bulb to Singapore server and to try it out again. But i will test it within the next 7 days.


#33

I set up a new account on the singapore Server and connected a color bulb to it.

I still cannot setup google assistant with yeelight actions (as in the screenshots I posted here earlier)

I loaded the pages in Chrome.

@coasterli: i will send you my new account.


#34

Hello,

Work for me in french language.

I setup google assistant on my phone, link google assistant to my yeelight account, and i can power on, off, change color of my yeelight strip led in FRENCH!

Thanks.


#35

It still does not work for me. Google Assistant will not create any device. I tried it with a RGB bulb.
(Samsung Galaxy Note 3 with Lineage OS 14.1 (Android 7.1.2))

I was able to set up Alexa to work with the bulb properly.


#36

Hi everyone !
I also want to use Google Assistant to control my Yeelight bulb color and set it in French (that’s a secondary issue), but I always get the same problem when it comes to link Yeelight Actions (using my Mi account, no other solution I reckon ?) to Google Assistant.
So when I add the yeelight actions service, I get to the login window, I confirm, it tries to go through but always tells me something like “impossible to update this setting, check your connection”
Is there such thing as a “Yellight account” that I’m missing ? Or does everybody use their Mi account like I’m trying to ?
I was logged to the Mainland China server in the first place but I’ve swtiched to Singapore (as I’ve read above), I’ve also tried the US and the US/Singapore servers but still no success, the connection yeelight/google assistant is always the problem.
Now I’ve finally tried through IFTTT and I can switch on / off my yeelight bulb color, but I thought I could do the same action without IFTTT (am I wrong ?).
So if anyone could tell me anything about that, I’m pretty sure there should be a way to use the lamp without IFTTT thanks to the Google Assistant recent updates.
(by the way I was misguided at some point because of my google now widget, and as you wrote on this thread one should not make that confusion google now / assistant)


#37

I am using my Mi Account. I dont know if there is a special Yeelight account.

I am interested in how you got IFTTT to work. Because IFTTT also does not find any Yeelight device.

But i will wait until the Singapore server will be able to communicate with my home automation by Xiaomi. And i will use Alexa then to control the Yeelights.


#38

As I can’t link google assistant to my yeelight/mi account (whatever the server I choose) I kept searching and I’ve found videos on youtube helping to make it work through IFTTT.
Example with that one : https://www.youtube.com/watch?v=_SBtdgP8nMQ
(If your yeelight is already connected to your network, the ifttt tuto really starts after 00:31)
The video is quite fast so maybe I should develop what you see on the video :

  • in the ifttt app, go to “My applets” (bottom right)
  • click + (top right)
  • click “this” and choose Google assistant, set your phrase for the action you choose (that’s the part where I was able to choose the French language)
  • click “that” and choose “Yeelight”, choose the action, your connected light(s) should appear and finish setting up the action.

Hope it helps.
But again, I don’t know if I have to use ifttt like I do (it works so that’s fine), and I’m wondering if some of you manage to control their yeelight without ifttt. If you do, I’d like to know why I can’t link google assistant to my yeelight/mi account (it tries, but refuses).


#39

I was able to set up the Yeelight with Google Assistant on my phone. In my case, when I clicked to link the Yeelight (as I described in OP), I was getting a differently localized landing page for Yeelight. Nonetheless, after I set Chrome to be my default browser, it worked fine.

I also had IFTTT, and yes it works great! I’m not sure how nice Google Assistant works in languages other than English - if you can set up custom voice commands like you can in IFTTT -, and I’m not sure if using one or the other makes a difference when using LAN control (to avoid lag).

FWIW, I’m actually using both now: I have the default commands set up on Assistant (turn off the lights), but also made some custom IFTTT commands (dim the lights; give me more light; turn up the lights; I’m going to bed, etc) with some nice Assistant replies (e.g. IF I say “I’m going to bed”, THEN lights turn off and Assistant replies “nighty night!”).


#40

So it seems that some of you can control yeelight only with google assistant and ifttt could be seen as just an extra.
For my part, I don’t know what I could / should change to make it work only with Google assistant considering that:

  • my color bulb is on Singapore server
  • chrome is my default browser

Every time I try to add the device through Yeelight actions, it tries but stops and rejects, telling me to check my connection (?!). Of course I’ve re-typed my mi account login and password to make sure everything was alright.

So, yeelight staff, any possible help with that please ?