Yeelight IFTTT service is now officially published


#1

Hi all,

Our IFTTT service is officially launched this morning, thanks for all your support and beta testing.
To whom just get this news, you can use Yeelight IFTTT service by following method:

  1. Download Yeelight Android test app here or update your iOS Yeelight app to the latest version.
  2. Logout the app and select Singapore server and login.
  3. Reset you bulbs if you are not seeing your bulb in the device list and re-connect them.
  4. Search “Yeelight” service IFTTT and connect to it.

Thanks,
Wilson


#2

本主题现在是横幅主题。它将出现在每页的顶部,除非用户将其隐藏。


#3

本主题已经不再是横幅主题。它将不在每个页面的顶部显示。


#4

that’s really awesome! good work!
i’ve updated my android app and connected the ifttt service - but when trying to configure an applet it doesn’t recognize any of my yeelight bulbs/groups and just says “options unavailable”.
anything i can try or is this just a bug?


#5

Hi, why does it work only with android 7.0 Google Pixel devices and Google Home devices?
Can i make it work on my android phone with Google Now?


#6

Which action did you choose? For set_color or set_color_tempreture, only color bulb or light strip applies, if you only have a white bulb, then you will see “options unavailable”. For “set_scene”, you have to create one through Yeelight app.
BTW, did you switch your bulb to Singapore server? You need to change your locale (in settings–> locale) in your Yeelight app, reset your bulb and re-connect it.


#7

Sorry, I don’t quite understand your question. Do you mean Yeelight App only works on some type of Android phone. Is your question related to IFTTT or some type of our devices?


#8

You need the “Google Assistance” in order to use the voice commands in IFTTT. (The Google assistance is officially exclusive of the pixel and pixel xl, but you can try to install it on your phone, there are some tutorials on the web).


#9

For IFTTT, we only provide a service that can be triggered by some other events, we have no control of the trigger side.
As stated in previous post, we will support Echo and Google Home later, which will support direct voice control.


#10

Hi,
I tried to activate the service after relogin setting sg server locale and readding my yeelight but when I want to turn on IFTTT the lights list shows “option unavailable”.


#11

Which action did you choose? For set_color or set_color_tempreture, only color bulb or light strip applies, if you only have a white bulb, then you will see “options unavailable”. For “set_scene”, you have to create one through Yeelight app.


#12

thanks! that did the trick @Singapore locale
is there a way to interact with a group of bulbs through ifttt? i can only see specific bulbs.


#13

Group feature is planning, for now, please add several actions on one trigger.


#14

#15

hi,
any plan to support china server? i need to add my yeelights to china server so i can integrate with mi smart home sensors as well


#16

No, IFTTT with China server is very slow and very unstable. We have no plan to support China server. Sorry for this awkward situation. Maybe you could ask smart home sensor team to support Singapore server :relaxed:


#17

thanks for quick reply and clarification.:relaxed:


#18

hi,
I have a problem with the Yeelight app and scene. when I set the scene to sunrise, so I will wake up with sunrise light, it just change the color from green to blue to yellow to red and so on. I want the scene so I can use it for IFTTT.
anyone a solution?


#19

Just use “set_color” action of IFTTT service, select “sunrise” and it will wake you up.


#20

Yes I can do that but I’ve 2 Yeelights and want to change both at the same time. Is it possible?