Ceiling light 650 not connecting to App

So this is why connection fails, the bulb can only work with a router using WPA/WPA2 encryption method with a password, 2.4 ghz. Please have a check about it.

And this is the reason (IMHO) why 90% of the connection fails… just read the review:

Laggy web portal
Very slow performance
Severely lacking in features

Serious performance issues
Lack of USB ports
Massive power supply unit

People have crappy routers, and especially ones they got from providers are pre-configured etc…

Yes all those configurations are set.

I have read the reviews on the Hub 3 previously.
Although I have to say I’ve not had any issues. I have a multitude of devices connected to it at 2.4ghz and 5ghz.
Including cheap emylo smart switches to convert my standiard lamps to smart ones. These connected straight away without issue.

Well I bought a new router and STILL the light won’t connect. I changed the dns and no connection.
So that’s everything tried.
Looks like I’m left with a defective light that can’t connect.

Well after several attempts the light does look like its connect to the router as its showing up within the connected list. BUT it does not show up in the app. I’ve reinstalled the app but still no change.
Can YEELIGHT staff please check my account to see if there are any connected devices showing please.
I’m about to give up very soon and look into other smart light products.

Please use another phone to setup a hotspots with 4G network and try connect the bulb to it.

I have tried that and the host phone shows 2 connections but the app still doesn’t display the connected light.
My new router a Netgear nighthawk X6 shows the ceiling light within the connected devices list and has assigned an I.P. address.
Why would the app not display the light when it has connected to the router.

Apps shows lamps that connected to your account in xiaomi cloud.

Which step do you stuck in the application, please provider screenshot of issue.

This is a video of what happens.Please click the link
https://youtu.be/uwSl2pqbGNo

@zhangxin Please take a look at the issue.

Any update please.

Hi Robble,
Sorry for the late response. Please send me your xiaomi account id and the connected server. We will check the status of the light from backend server.

Hi
My account number is 6159771749 and the server is mainland China. I have tried several times on all servers.

There is no devices under your account. So actually the light did not connect to the server successfully. I will look into the issue of wrong tips of Yeelight app.
Have you tried MiHome app or android phone for connecting the light?

Yes I have tried Mihome and android tablet.
Mihome just timesout and android version on Yeelight does the same thing as the IOS version.

Hi Robbie,
Please see this thread: Connection timeout issue

I have seen that thread and have tried it a few times.
I will give it a try again.

After several connection error messages I eventually connected to the staff account. I managed to update the light and finally it has now connected through my account and showing in the yeelight app.
We finally got there.
Thank you.

Just to add I have reset the server Mainland China to German as i couldn’t get Alexa to work.
It all works perfectly.
I’m finally a happy man :slight_smile:
Thanks.

1 Like