Ceiling light 650 not connecting to App

I have installed a 650 ceiling light. I have connected the remote control and all works well but I can’t connect the light to the app. I have made sure my router is on 2.4ghz. I have reset the light many many times and have tried changing to all the servers listed but I still can’t get it to work. The light starts to pulsate as if its in the process of connecting, the app starts the count but then it stops and the app reverts back to the set up device page. I am in the UK.
Please someone help
Thank you.

  • There should be no special characters in the SSID or WiFi password
  • You chould be on Chinese server
  • Look at the router DHCP list and see if it assigned an IP adress to the CL

Thanks for your reply. The router name and password have no special characters.

I have tried the Chinese server

I have several things listed as unknown so not sure where in that list the light could be.

Also I’m not sure if it’s getting as far as connecting to the router. And according to the app Germany is the recommended server.

Please click YouTube link to see what happens when trying to connect.


Yeelight staff please help.

1、Make sure the lamp is connected to your router.
2、Try changing DNS of your router to

That is my problem. It doesn’t seem to be connecting to the router.
I have looked at connected devices in my router settings and can’t see it.
I have a virgin media hub3 here in the UK and there doesn’t seem to be any options to change the dns settings.
What is the mac address for the 650.

Anymore help please. issue still not fixed.
Unable to change DNS settings as this is not an option for my router Its a Virgin media Hub 3.
Could the light be faulty.

So this is why connection fails, the bulb can only work with a router using WPA/WPA2 encryption method with a password, 2.4 ghz. Please have a check about it.

And this is the reason (IMHO) why 90% of the connection fails… just read the review:

Laggy web portal
Very slow performance
Severely lacking in features

Serious performance issues
Lack of USB ports
Massive power supply unit

People have crappy routers, and especially ones they got from providers are pre-configured etc…

Yes all those configurations are set.

I have read the reviews on the Hub 3 previously.
Although I have to say I’ve not had any issues. I have a multitude of devices connected to it at 2.4ghz and 5ghz.
Including cheap emylo smart switches to convert my standiard lamps to smart ones. These connected straight away without issue.

Well I bought a new router and STILL the light won’t connect. I changed the dns and no connection.
So that’s everything tried.
Looks like I’m left with a defective light that can’t connect.

Well after several attempts the light does look like its connect to the router as its showing up within the connected list. BUT it does not show up in the app. I’ve reinstalled the app but still no change.
Can YEELIGHT staff please check my account to see if there are any connected devices showing please.
I’m about to give up very soon and look into other smart light products.

Please use another phone to setup a hotspots with 4G network and try connect the bulb to it.

I have tried that and the host phone shows 2 connections but the app still doesn’t display the connected light.
My new router a Netgear nighthawk X6 shows the ceiling light within the connected devices list and has assigned an I.P. address.
Why would the app not display the light when it has connected to the router.

Apps shows lamps that connected to your account in xiaomi cloud.

Which step do you stuck in the application, please provider screenshot of issue.

This is a video of what happens.Please click the link

@zhangxin Please take a look at the issue.