No connection to Mi LED Desk Lamp with own account

Hi, I can’t connect Mi LED Desk Lamp to Yeelight app with my own account. Using lixin@yeelink.net account, china mainland server, I’ve updated to xxx58 firmware, but I have no connection using my own account.
Could someone help me please? I bought the lamp also to personalize it through the app, and after 3 days of attempts I’m still having no success. My id is: 6153134055

So you can connect with lixin@yeelink.net but not with your account?

I’m having the same exact issue. I can connect using the yeelink account and upgrade the firmware. but when switching back to my own account, it has the same issue of connection time out.

Please connect with yeelink account again to see if the lamp is the latest firmware version. If yes, it should be ok with your account, I have tried from our lab.

This fixed my problem. thank you very much. God bless

I’ve not fixed mine :pensive: I’ve last available firmware, seen form yeelink account, but when I come back to my account I can’t sync my lamp, I reset every time, put router wifi password, connect to lamp wifi, come back to app and get a time out error very quickly or waiting a lot with process stopped at 25%

It seems the lamp doesn’t connect to your router, please check if you can see the lamp from DHCP list.

Hi DingYi, I am also encountering the same issue. When Im on Yeelink account, it states that theres no latest firmware update but when i connect back to my own account, connection with my lamp times out. My MI id is: 6188453073. Pls Help!!

Hi, what’s the firmware version of your lamp? Please use Yeelight application and select Mainland China server.

I can see the lamp in dhcp list, but I can’t complete the connection process, connection failed. I’ve tried everything described also here: Connection timeout issue
How can I fix this?

What’s your xiaomi account? Please try changing DNS of your router to 8.8.8.8 and connect again.

6153134055, I’ve tried changing the DNS of router as you said but nothing change, I still can’t connect to the lamp with my account

1、Logout your account and login with account: lixin@yeelink.net , Password: yeelink1234 from Yeelight application.
2、Try to connect device with the account. Update firmware once connected, then reset your device and try again with your account.

As I said, I tried everything you said here and in all the other posts, not once, thousands times…but I’ve tried another one. With lixin@yeelink.net no problem, but no firmware update available (1.3.7_0058 installed). With my account I can’t connect

Latest firmware version is 1.3.7_0058, if you have this one, your account should be ok, please have a try.