"Connection Timed Out" Yeelight Color V2


#1

I recently bought a Yeelight LED Color Bulb V2 from a retailer in Greece. I did download the Yeelight App, and i connected to the German server at first ( i am located in Greece ). The app guided me through the process of setting up the bulb, i could see the lamp on my network, but at the final connection step i keep getting the message “connection timed out” at 99%.

To make matters more clear, my router SSID is letters only, internet band is 2.4 Ghz, the bulb is nearby my router, tried multiple servers on the process, but i still cant connect it. Also tried the MI Home app, same issue there, no matter the server selected.

Are you currently facing any issue with the app or your servers that may prevent the bulb from connecting? Can you provide me with a troubleshooting that i havent yet tried? ( I have seen all the FAQ’s and followed all suggestions of your personnel through your forum.).

In case that you do face a technical issue, let me know about it, cause i want to hold on to the bulb, if a fix is soon to be released. In any other case, let me know if i should return the bulb to the retailer and proceed with another option.


#2

Anyone of the Yeelight Staff has any answer? Its a shame, XIAOMI never had that major issues with other products… :frowning:


#3

Have you tried resetting the bulb?

You can reset the bulb by turning the switch of and on again for 5 times. The bulb will then flow colors, and you are able to configure the bulb.

Let me know if this solves the issue.


#4

Already done all those things, tried everything. Even the dumb ones like changing router SSID, DNS and stuff. Nothing of that works. It’s a problem of Yeelight server or app, just need someone to tell me if it’s gonna be fixed or if i should leave Yeelight as an option, as TP Link bulbs i bought work fine.


#5

Have you tried a different server yet?


#6

As mentioned in my original post, i tried everything i could find, including server changes. That stuff though are useless, as the bulb should operate normally in every server, as all the other smart bulbs do.


#7

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

And at last please use another phone to setup a hotspots with 4G network and try connect the bulb to it, I want to make sure if the bulb is ok.

Or could you have a try with changing your router’s DNS server to 8.8.8.8 instead of using automatically allocation?

Thanks,
Andy


#8

I have already done all that things, i saw this exact same answer to other people’s posts about the same issue. Nothing for me though.

My ISP is not blocking your servers, bulb is on DHCP list, i can see the wifi from the bulb, but at 99% connection is timing out.


#9

Finally problem solved!!! In cooperation with xiaomi support we discovered that the problem was in DNS, so i kept my primary DNS from my ISP and entered the Google DNS as secondary, and the bulb worked just fine!!! Many thanks to the guys that helped solve the problem!!!


#10

Hi, much appreciate if you describe your solution more detail attach with pictures, so you can help other people have the same issue in Greece.


#11

Can you expain more detail,please


#12

Andy, you say the same shit everywhere! But your solution DOES NOT WORK!


#13

There are lots of things may cause connection fail issue, so I need to know the case you encounter. Do you think it’s the way that you can resolve the issue without any clue left?


#14

hey buddy I am in Turkey and ı need help very very much ı got the same problem. but diffrent one sometimes yeelight app doesnt detect my bulb and mihome isn’t detect yet can you help please ?


#15

Which device do you have? Bluetooth based or wifi based.


#16

ı have both , and ı have the same issue I check the network is 2.4 ghz I check the networks name doesn’t have a speacial charecter, ı tried with a diffrent device I did all the think that ı can when its reach the %49 its get slower and when its %100 its says connection time out I am very mad about it


#17

It seems there’s some problem when the bulb try to connect to the cloud, so please have a try with changing router’s DNS to 8.8.8.8.


#18

Andy,

I have a very similar “Yeelight won’t connect” issue along with many, many others. I can connect ANYTHING else to my networks successfully, so I know it isn’t a Wi-Fi or other local issue (like pretty much everyone else with this issue with Yeelight/Xiaomi products). You repost the same answer to everyone, but it rarely if ever seems to fix the problem as there seems to be a serious issue with the Yeelight servers or network somewhere.

I have multiple Yeelight devices, including a Gateway (Xiaomi) and a bunch of YLDP02YL bulbs. Nothing wants to talk to your servers. Not a single device. This is what I have tried multiple times so far.

  1. I have tried multiple ADSL routers, and even on multiple sites with different ISPs. In all cases the devices get an IP, but they cannot contact your Mainland China server from here in Australia.

  2. I have tried multiple different SSIDs and passwords, none with non-standard characters, and the devices get an IP every time, but time out connecting to the Mainland China server.

  3. I have tried multiple DNS providers including various ISP DNS as well as 8.8.8.8, 1.1.1.1 and 9.9.9.9 with no change in the outcome at all.

  4. I have tried pinging the *.ot.io.mi.com servers as you have suggested elsewhere and all resolve to an IP perfectly, however sg.ot.io.mi.com times out on every single site - even though on different sites it does resolve to different IPs that are being used in what appears to be a server farm there.

  5. As I have said, I have tried from multiple sites, using multiple routers/Wi-Fi (including trying to hotspot off a 2nd Android phone) and multiple devices and all receive an IP but cannot connect to your Mainland China servers no matter which ISP I have used.

It really does look like there’s a connectivity issue between your Mainland China servers and the rest of the world.

What is also a real shame is that many of your devices are only compatible with the Mainland China servers and simply don’t work anywhere else, on any of your other servers.

Could you please look into this issue - it really makes Yeelight/Xiaomi look like a company with a great many products, but a significant inability to understand how to make them work.

Can I also say thanks for answering these questions in here - you seem to be the only employee regularly answering questions in here, even if the answers you give aren’t really resulting in fixing the issues or (yet) working out where the issue is so it can be fixed at the Yeelight Cloud for all users worldwide.