Yeelight Alexa Skill is officially published !

Hi Dear Yeelight users,

Thanks for your patience! Our Alexa skill “Yeelight” is now officially published (finally), now you can control your Yeelight devices through your Echo/Echo dot. Remember to switch to Singapore server firstly.

Search “Yeelight” in your Alexa app skill page or click following link, finish account linking and discover devices. After that, just have fun.

If you like our skill, please write some review and give us a nice rating :-).

Wilson on behalf of Yeelight


I just discovered that the skill has been published. Unfortunately account linking does not work for me (Amazon error page) and so I cannot activate the skill. (German user, Singapore server, IFTTT integration is working).
I just checked my me account and it shows YeelightAWS permission, if that helps.

Edit: Removing the permission and linking again worked.

So now it works well?

Yes, works nice and almost without lag. Thanks!

ohoho trying it now ! ill comeback later with things to say

edit : well no problem so far … works like a magic …

Is possible change scene/color of Yeelight RGB bulb via alexa?

Thank you so much!!! Works great.
Any chance of a guide to create Scenes Alexa can recognize?
Thanks again! I’ve been waiting for this so much :grinning:

Just create the scene in the YL app. You can discover existing scenes in Alexa as own devices. To switch a scene just say Alexa, on.

Thanks a lot. It’s working

Yeah, Thanks😀

Hello! how can I create a scene in the yeelight app which uses the recommended scene?

I mean: If I click on the recommended scene (romantic i.e.) the bulb starts the scene (a loop of red/rose colours) and it’s ok. I want now to start the scene through Alexa. I created a new scene (and so a new device for Alexa) calling it “romantic”. How can I edit the new scene “romantic” in order to execute the romantic loop already implemented in the app?

Thank you!

The next app update will let you do that, please stay tuned.

Yes, you can create scene from Yeeligt app, which can be discovered by Alexa.

Looks like there is a small bug in the Alexa skill. If you order Alexa to dimm down the lights by voice it works for the stripe but not for the bulbs. Could you please check?

It should be caused by packet loss, the bulb has passed the strict skill certification, it should behave correctly. Also, please make sure they are on the latest firmware.

Very cool for an initial release.
Found out that the following phrases work too:

“Alexa, make the (your light name) 100%”

Pretty basic for now, but the essentials work reliably. Well done.

Looking forward to changing colour and setting scenes!

You can use scene management to create scenes and then run device discovery again. Then the scene will be shown in your device list.

Now it is working, bulbs get dimmed from Alexa as well. Thx for your support.

I understand that I have to switch to Singapore server to use the skill, but is there any way that I can still use the mihome app? Thanks