Issues connecting Yeelight LED Strip 1S to Yeelight App

Hello, I would love to have your help please.

I bought 2 Yeelight LED Strip 1S and have them connected to power.

I downloaded the Yeelight App and tried to connect the 2 strips to the app.

I set the Yeelight to reset mode and followed the instructions on the app.

I tried adding the new device and after adding wifi details, the status bar goes to 15-18% completion before it jumps to device name screen. Enter default name, set to Bedroom. The device seems to be successfully added and appears on the device list with the On/Off switch. But then the device disappears immediately after a few seconds. Further attempts to connect the same device gets the same results.

(I must say that we have 2 Samsung phones and 1 iPhone, and both Samsung phones didn’t even recognize the strips, only on the iphone I managed to find the strips and add them to the app but then as I said they disappeared).

I found this topic which sound similar to my issue…

How can I fix that?

Hello, could you please provide the product model so that we can confirm this product? You can determine the model name by the WiFi name of the product itself, and you can provide us with the WiFi name in the screenshot.