Can't Link Yeelight Actions to Google Home


I didn’t found your WiFi devices, can you tell me your device type?


yeah, Google Home can’t supported Bluetooth device!
If you want to use Google Home, please connect the WiFi device to the Singapore server or US server.


My Xiaomi id is 1758024771. The device is a colour bulb, connected to the Singapore server


Oh sorry, I didn’t found your devices in the background, Can you take a screenshot on Yeelitht App?


Here it is


Please take a screenshot include left menu MI ID


For example:


Screen shot with left menu


OK, I log it .Please sync devices on Google Home app.


Hi, now when I try to link Yeelight account, the browser takes me to page with Yeelight account code 1758024771 - a different code to the Yeelight app code 1758015471. it then says trying to link, but no device shows. Is the different codes the problem?


You should use 1758015471


Hi Yusure, sorry to be a nuisance, but how do I log in to as 1758015471? To my recollection, I have only created one mi account, and that gives me id 1758024771. I can’t find a way to login using the account id, only by email ( or phone. I reset my Yeelight in case it gave me options, but it came back as id 1758015471, no chance to change it to 1758024771


I understand your issue, please PM your xiaomi account and password direct messages to me, i check it to help you, when the problem is solved, you can change your password.


Thanks! Finally got it. I have two accounts, one using my email, the other using my phone number. I kept trying using my email, but the bulb is linked to my phone number. By adding to google home, logging in with my phone number (including country code) instead of my email, now the yeelight is linked to google home!


Hello I have the same problem. Can log in and it’s trying to add the devices but nothing is there after it finished.
My Mi ID: 1251101573 devices are 2 color Yeelights.


China server can’t supported. Please change Singapore server or US server after reset devices.


Thank you very much! I tried changing the server but it didn’t work but after the reset it worked :slight_smile:


Yep, I’m affected too.

Singapore Server, MI ID 15811984727, Says it adds but no devices ever show, very annoying as I have a number of other Yeelight products on the way.

Help appreciated


Hi Gaijin,
Your MI ID has error, please open Yeelight App, look at left menu will find MI ID.


Ah yes, my mistake, one digit too many

Should be 1581984727