Xiaomi YLXD01YL Yeelight Smart Ceiling Light never completing "add device" in app


New in this forum and this is my first entry - forgive me in advance if I breach rules that I’m not aware off…
I did buy several year ago 3 sets of Xiaomi YLXD01YL Yeelight Smart Ceiling Lights and wanted to install them.

I’ve reset the light by ON/OFF 5 times and I see the yeelink-light-ceiling1_mibt1a67 on my wifi.

I’ve installed latest YEELIGHT app on my android phone and connected to German server (I’ve also tried on Singapore, US and China servers later on, without any success).

The Yeelight app detects the Yeelight Ceiling light and starts installation procedure.

I’m requested for my Wifi router and select my “SMC” on 2.4GHz ( I’ve disconnected my 5GHz) and put in my password.

The Yeelight ceiling lamp is updated with my SMC router + password, as later on I find it back in my network with a DHCP provided IP-address: (and I can ping it successfully).

Now Yeelight app completes the procedure but then I ALWAYS get “connection timed out” and the device is not added in the Yeelight app.


→ How can I get this fixed???

Thanks in advance for any tips or support from the forum group…

Hi, Try connecting to wi-fi hotspots on other phones. If it works, That’s where the Internet comes in

This post may be helpful to you, you can check it out.


I tried the hotspot method but I get the same result ( connection timed out) - even used Germany and USA (Oregon) servers to see if there was a difference.

My Yeelight Ceiling lights (3 pirces) are still unopened from 2017-2018, so I might need to get some update so it can work with latest Yeelight app?


I think this would be a good one to try, but the email-address + password combinatio9n does not allow me to login… :frowning:

I hope the Yeelight support team can get me unblocked as I have 3 pirces of these ceiling lights that I now (finally) can/want to install

Or anybody else with tips?
rgds Rudi

Can you send me Your Xiaomi account number

Hello. What’s Your Xiaomi account number

You can try this by re registering as an account, selecting Chinese mainland, and then using that account to connect to your network device and update your firmware. Then, add the device to your current account.

Hi, my account number is 6423190288

Tried this whole procedure (created new gmail address, connected to chinese server, registered new MI account with the new gmail address and tried to add the device) and same unsuccessful result: “connection timeout”

Can I get a correct and proven solution from the Yeelight support group ?

your xiaomi account is bigger than 4294967295 (32bit).

Is your new Xiaomi account bigger than that, too?

When creating a new account, choose the Chinese mainland server. It can’t be bigger than that ID( 4294967295

My Mi account number 2214185312 password aaa75662791.
When you log in, select the Chinese mainland server.
Use my account to log in and update the device.
He may need a verification code, and the time of the Verification Code is 1 minute, so I have to give you the Verification Code Within 1 minute before you can log in successfully.
We have different time zones. It’s 9:38 in China Standard Time and 3:38 in Germany. I’ll wait for you for 10 hours. Please reply to the post in time. Thank you.

It is confirmed that the problem was related to an xiaomi account is bigger than 4294967295 (32bit).
Having received access to Yeelight support account smaller than this, I was able to get my Ceilling lights dicovered and then firmware upgraded.
Once the FW was upgraded, there was no more problem to discover them in my own account…all worked fine.

I’d like to thank the Yeelight support team, as it is not easy to get a solution working, especially since there is a 6 hour time difference , meaning ping-pong emailing.
But Yeelightfae kept giving support and solutions to try, until successful completion. Kudoos!

:grinning: :grinning: :grinning: :v: :v: :v:

I have the same problem.
My account number 1774366439.
Could you help me with this problem?

My YLXD76YL (C2001) is having the same issue of timeout after upgrading to 2.1.7_0014 firmware. I tried with 2.4Ghz Wiffi only, it is fine, but my router has autoswitching 2.4/5Ghz, it worked before but now fail. My account is smaller than 32bit (245034605)

After a few months, I decided to revisit this issue. I changed a few settings on the router and I finally found out a feature why.

I turned off AMPDU function. It seems that the latest firmware for me, changed the behaviour on how the device interacts with AMPDU. AMPDU in my router is used so that multiple data to the same destination will be packed together. This helps enhance performance when there are many small packets, but caused problems with this.