Yeelight Meteorite not working with Alexa


since a couple of days, my Yeelight Meteorite is no longer recognized by Alexa (“Device does not respond”). Neither with voice commands nor directly via the Alexa app.

My Yeelight Ceiling Light works without any problems with Alexa.

However, Meteorite can still be switched on/off using the Yeelight app or the remote control.

This is the troubleshooting I have done so far (without success):

  • resetting the Meteorite (multiple times)
  • Deactivating/reactivating the Alexa skill

One thing I haven`t done so far is changing the Yeelight server, because this means a lot of work to me as I have 8 devices.

Any suggestions?

Thanks in advance

No response so far, that’s quite annoying. Thanks to the comments below the Yeelight Alexa skill, I have now at least a workaround. Telling Alexa to put the Meteorite on 100% will do the job. That means, the Meteorite IS responding to Alexa (switching it off works also). Makes no sense to me why the normal command does not work.

Do you have also problems like this?


I have the same identical problem

Yeelight staff, could you please respond? Your product is quite unusable w/o smart home functionality.

Hi, could you please try the Alexa app to control Meteorite

And have you tried to re-enable the yeelight skill?

Alexa app has the same result = device not responding.

And yes, I already re-activated the Yeelight skill twice, as I already wrote in my initial post.

Any news here? It`s quite clear that Yeelight need to check the Alexa skill.

Same issue here.

Meteorite is controllable with the Yeelight App
However I can turn it off, but not on with Alexa

I tried so re-add several times.

Any ideas?

Yellight needs to fix the Alexa skill, but they didn’t so far.

Looks like it’s working again (as of today).