Mi Bedside Lamp 2: Alexa can't turn on since a few days

Hi,

I’ve got a Mi Bedside Lamp 2 on European Server firmware 2.0.6_0030. The lamp has no issue with Mi Home app. It’s always online with the router: i can turn on and off from the app.
On the Alexa App I had the Xiaomi Skill installed.
Since a couple of days I can’t turn the lamp ON only from the Alexa APP or using my voice command on the Echo. The Alexa app shows the lamp as ONLINE but when I try to turn it on the Alexa app shows a generic error “An issue has occurred”.
If I turn on the lamp from the Xiaomi App, I can use the Alexa app or voice control from Echo to activate every feature…for example I can change color temperature or turn it off.
Again, after turning it off, Alexa will not be able to turn it on again.
It’s not a wifi issue at all (for the fact I can immediately turn it on from the xiaomi app).
In the same network there’s also a Mi Led Ceiling Light that has no issue at all with Alexa voice command on Echo (I can turn it on or off whenever I want).

This issue has started since a few days: no change has occured to my actual network configuration. I suspect that Xiaomi updated their Xiaomi-Alexa Skill introducing a new bug.

1 Like

It also happens to me, seems like a bug in the alexa sill because it works perfectly through the ok google app. Until they fix it, you can tell alexa to set the light color to white or whatever color you want and it will switch on the light.

1 Like

I opened a ticket with Amazon Alexa support. They are investigating if the issue is on their side. The Xiaomi Alexa skill has not been updated so far (as well as the Yeelight skill). So it could be an issue introduced by some Amazon backend. In the next five days Amazon will let me know their investigation.
Meanwhile it could be interesting if Yeelight give us support in this thread (I forwarded the thread to Amazon too of course).

1 Like

Same problem here. Also running 2.0.6_0030.
For now, I have been turning it on using the voice command for change of color.
I do hope they fix it soon.

3 Likes

Same problem here - I have four of these - they’ve all stopped turning on via Alexa - they’re find turning off changing colour / brightness - but Alexa says there is a problem when trying to turn on (all of a sudden after 2 years use with no problems)

1 Like

Amazon replied to my ticket opened. They double check their logs on their cloud platform…the issue is due to Xiaomi Alexa Skill I’m using…it’s a bug on the skill…let’s hope that Yeelight - Xiaomi will fix it soon

I have two different Yeelight. Same problem started a few days back. Alexa can turn off but cannot turn on. Hope Yeelight can fix this asap.

Judging the fast Amazon response and the total lack of interaction from Yeelight, it seems that they have no interest at all in this bug.

The problem is the new Firmware.

No, I have no new firmware installed. I’m on 2.0.6_0030. It’s the same firmware version I had before the issue started. So the issue it’s not firmware related.

YESSSS!. For me this is the NEW FIRMWARE!!. Bedside 2 go with 1.xxxxxxxxxx

For me 1.XXXXXXX WORKS!. You can go to the 2.0.6_0030 forum and read it.

I repeat, it worked with 2.0.6_0030 until 7-10 days ago… It worked with that firmware for months. They changed something on their backend…and this change is causing this issue. I’m happy you’re experiencing no issue at all with 1.x…but there was no issue at all even with 2.0.6…

It maybe a regression bug on their backend software infrastructure. The Xiaomi Alexa skill has not been updated since months too…so we can exclude that the issue is the skill itself. They updated their software backend recently and then we had that issue.

Btw, if not fixed in a few weeks Amazon should remove the “Alexa certified logo” for this lamp

I agree, I gave back all my echo dots and I bought google nest for this reason…the lamps worked fine with alexa also with the latest firmware and Singapore server…the problem is the not asian servers like Frankfort (Germany)

That sounds great!! Issue only on NON Asian server? So it’s quite sure now that this is a backend issue.

Yeelight please fix it soon!

Ok but here the people said the problem is the Alexa skill…for me works well ALWAYS in 1.XXXXXXX Firmware version. For many people works for some days in latest Firmwares. But the first Firmware is more stable for me. I used this lamp for a few days…but when I update the problems begin inmediatly.

I am in China Server my Firmware no is 0030 is 033

I think the problem is with users outside of China. Especially in Europe, perhaps due to data protection law or firmware restrictions. Sometimes new implementations in a firmware are not activated immediately. And that’s why it seems like a failure in the servers. I don’t think they take care of their customers in Europe. Surely in China they do not have these problems. My lamp is global version should not have problems. However Xiaomi restricts more the use of global versions in Chinese Servers. An example is the Roborock S50 vacuum cleaner. In the end it is better to use it with Chinese firmware if you use that server.

No matter of China server…I bought the lamp from the Xiaomi official Italian store. It should operate correctly on European server. They have to take care of customers WORLDWIDE. I’m quite unhappy for the fact we have NO REPLY to this thread at all from Yeelight.
I will not switch to chinese server. European one is the most suitable for me as I’m in Europe (low latencies) and of course GDPR regulation too. I expect that firmware version are different due to local testing…version 2.06.6_0030 is tested for European countries…if a new version is needed they will deliver throught European server ASAP.

I can not use another server. I must use the china server. I have 40 mi home devices…many dont exist in Europe. If you has only the bedlamp…I think the latency is not a problem…is more important if you has optic fiber in your house. The light speed is 300.000 km per second. China to Italy is a 0.01 sec or less. China Server always was a better option. I has many experiencie with devices… You can try to another server.