Yeelight Bedside Lamp v1 connection timeout isdue

Hello!
Today both my Bedside Lamps (gold edition) suddenly went offline and stopped connecting to my wifi. They worked without any issues more than half of year.
I reset them then started adoption process, but at third step (Connecting device to network, channel 2) i always got an timeout.
I am using China mainland server, and located in Russia.
I tried to reinstall app, checked that my router has dns server 8.8.8.8 set, tried to adopt lamps with yeelight app and with different servers (us and Russia) - nothing helps.
Please help me. My ID is 1648537391.


Anybody?

Ok folks I figured it out.

TL;DR:
Use Dns over https by Cloudflare.

So “thanks” to support that never answered me. Thats weird guys.
I have started wireshark and determined that lamps uses at least this servers to connect:
ot.io.mi.com
ott.io.mi.com
api.io.mi.com

I have checked them with host utility and writed a list of their ip adresses. I used 8.8.8.8 DNS resolver for that. I have checked all written ip address with ping - almost all does not answered via icmp.
After that I logged to virtual machine located in US and checked NS records above with host utility too. And noticed that A records that google DNS returns in US differs from A records returned by google in Russia. Thats weird.
So I have mikrotik router that supports DNS over HTTPS so i set up a cloudflare DoH. You can google the process by keywords “dns over https mikrotik”
After that I was able to connect my lamps to mi home app and enable LAN mode for my beloved home assistant.
That’s really ridiculous, my time spent to this investigation costs more than 4 times expensive that this damned lamps.
Thanks for nothing Yeelight and let God bless you.

1 Like

For god sake. Fuck this chineses dog eaters and virus spreading. I also spent a lot of time to connect my lamps that used to work very well in the past. I hope it lasts, because I am not in the mood to do what you did. I think I gonna sell this lamps from hell (while they are still working, so I can record a video) l and buy that ones that works with a remote control and don’t ask for wifi password.

Why the hell do a lamp needs to connect to a server? It’s a fucking lamp inside my house!

2 Likes