Yeelight Toolbox


“Discovery message succesfully sended through IP”

So I assume I should see a packet sent to in wireshark ? Because I don’t see any.


Yes, you should (EDIT: not sended to that IP, but sended FROM that IP). I have tried to be very careful checking that the program sends the message through every possible IPv4 interface to avoid that the message doesn’t go through the correct one. If it says that the message have been sended through that IP and that is your local network IP… it may be right, I guess.

Honestly, I don’t know what can be happening… Is actually your local network IP? Isn’t it the usual 192.168.x.x? Could you check with ipconfig command on CMD? Maybe that IP is a strange one, I don’t know.

As I previously said, if the official demo doesn’t work too, I think staff devs should look into it. @Yeelight


No, all my ip on my network are the usual 192.168.0.x

I have no idea where come from. How does your tool got this adress ?


Yes, I noticed that strange IP adress as well, my IP’s are also 192.168.1.x


In your case, Pablo’s program works as expected, it finds the bulbs (some more than once, don’t worry). It sends the discovery message through ALL the network interfaces on your computer, so ignore the IP shown there.
Also, I’ll update my app to add logging capabilities, soy you can send those to me.

In @matheod 's case, even the official demo app doesn’t find bulbs, we can’t really help there.


I don’t worry, it is just strange :slight_smile: BTW, that seems to be some Microsoft Virtual Wif iAdapter, and as far as I can see it is disabled, so trying anything on it is a waste of time :slight_smile: So you need to get the status of adapter before probing :slight_smile:


Please try another version of my program to see if it solves anything now.
@matheod I don’t have so much hope on you because the official demo doesnt work on your computer, but you can give it a try to see if anything changes :pensive:


Still doesn’t work but thanks anyway.

Maybe Jordi could try to allow us to add ip of light to see if it work without having to go through the discovery phase ?


@jordi.id96 & Pablo097
Thanks alot for your hardwork. Finally v 1.1.7 is working flawlessly.


En mi caso funciona bien la aplicación de Pablo donde me detecta 6 bombillas aunque solo tengo dos, pero sigue sin funcionar el toolbox. Saludos.


That is just for testing purposes. My app only sends through the wifi or ethernet adapters


So it should work via Ethernet too and not only with Wifi?
Anyways my App is not detecting anything…
I was connected via Ethernet then I tried Wifi but it’s the same…
(I have downloaded SlimDX x64 too)

Edit : Wait I’ve found an important information to tell to users !
You MUST activate the “Local control” for EACH devices in the mobile application !
I just found out that 2min after writing this message, I had an illumination lol
Hope it can help some peoples :wink:


Yes, you need to enable LAN Control on each device. Then the app will detect them even through ethernet.


You definitely should add that in the first post, I think that it can help some people that have troubles :wink:


Sure, you are not the only one realizing that, I will update the post as soon as I release the new app version



I have tried the app on two different setups (PC, Win10, Ethernet & PC VM, Win7, WiFi) with the same results. App works fine, I can see, turn on/off, change colour on my bulb and lightstrip.

When I enable movie mode though the app freezes and is unresponsive. I have to kill it via task manager. Of course movie mode (which is what I mostly want) does not work.

Can someone please help?

Thank you very much.


By the way Jordi.id96, is it planned to add the group function ? :grin:



Read the first post.
Did you installed :

.NET Framework 4.5 or later.
SlimDX End User Runtime (required only for movie mode)




I already have .net framework 4.7.2 in my main setup. The link you provided is broken. I have installed SlimDX 4 for x64.


I am aware of the issue and I think I found the cause. I’ll release soon the next app version containing the fix. Thanks for the feedback!