Yeelight Color II - "Updating connection status, just a sec..." time out

Hey there,

I originally set up my lights in the yeelight app, and have been controlling them via google home ever since.

However, I recently signed into the yeelight app again because I got a new router and upon signing in again there were no devices listed, shortly afterwards they all disappeared from google home too.

I thought at first that maybe I originally signed in using facebook so I tried that next but my account number was the same regardless of if i used facebook or a password - so I don’t think that’s the issue.
Account number is 6174623989

I tried resetting the lights (off and on 5 times until multi-color flashing) and adding them again via the yeelight app but all of them get stuck on the “Updating connection status, just a sec…” message and eventually time out.

These are the bulbs I have https://a.aliexpress.com/_d8ZoaSM
I’m fairly certain they are the Color II model, because the wifi names show up as yeelink_light_color2_...

I’m using a 2.4ghz wifi connection
I’ve set the router’s dns to 8.8.8.8 and 1.1.1.1 to no success
I’m using the latest android app
Don’t know the bulb firmware but I did update them all when I first set them up about a year ago – late march 2019.

Any help would be greatly appreciated!
My smart lights are currently dumb lights and stuck on the last colour I had them set to :frowning:
Thanks!

Hi Jacob, today I had the same problem as you, and I finally get a solution. My context is more or less the same as yours, I bought the LED Bulb II (Color) on December 2019 and I set up my bulb correctly then, and everything work fine; but in my case I didn’t change to a new router recently, but I changed the password of my router and since then I got the same problem as you.
So what I did today was change the password of my WiFi net (2.4GHz) again and then follow the normal steps to vinculate the device (add new device, select LED Bulb II, reset the bulb switching on and off five times, select your device) and when you arrive to the window where asks to select the wifi network to make the vinculation, here you have to press the 3 points of your WiFi net and select “forget network”, then you must select again your wifi on the list of available networks and now it must ask for the authentication password, you enter the new password and now it must works, at least that’s what worked for me.
I think the problem is that the yeelight app save automatically the old password and doesn’t asks for authentication when you change it or change your router, so it is impossible to connect because it is not the correct password.
I hope this can solve your problem. Let me know any case! :call_me_hand:

3 Likes

Oooooh that could be it! I did change phones in that period too which could explain why it the app can’t access the saved wifi password. I’ll try tomorrow and let you know.

Nicee! Hope it works

1 Like

Yess sir! This did the trick. Just had to forget wifi network and re-enter password. Who knew it was that simple. Thank you so much!

1 Like

Unfortunately for me guys doesn’t worked. I have the same exactly scenario here… also use dns 8.8.8.8, wifi settings etc etc… Suddenly my light bulbs stopped working with Google Home… so I’ve checked the home app, yeelight app and nothing worked anymore.
I think it was some connection problem and checked my DHCP client list, and all my 4 lights still there responding a ping test.

I’ve tried to reset all lights one by one, and after the 99% config process, a error message showed like there wasn’t possible to finish the setup due timeout issue. After that it seems the light was configured and connected to my LAN, but the yeelight app doesn’t recognize it.

It seems a problem on The servers

1 Like

Makes sense… But there is not officially confirmed :frowning:

Try changing The server tô Ásia. Reset and configure again. It Will work

1 Like

Wow it’s working now… Thx bro

1 Like

European server is working this morning, already have my devices up and running fine.

Just had to forget wifi network and re-enter password. Who knew it was that simple. Thank you so much!