Can’t connect previously connected Yeelight bulb 1S color. Connection timed out.

I have a new 1S Color bulbs that have been functional for a week. The initial setup was successful and a bulb have been functional. After 1 week the bulb went offline and was unreachable. I removed it from yeelight app and attempted to reconnect it again and now it won’t connect. It says connection timed out at 100 percent by first attempt und at 50 percent by second attempt (try again).
After reset of the bulb the yeelight app can connect to the bulb, then it tries to connect to the server. The bulb flashing quickly and the yeelight app shows “Updating connection status, Just a sec…”. The connection status goes to 100% and then the app shows “Connection timed out” error.
My MI Id is : 6274613650, I was on Europe server, my router security using WPA2.
I have tried using mainland China, Germany, and Singapore servers – No success.
I have tried to setup a hotspot with another smartphone and connect a bulb through this new router (hotspot) – no success.
Could you see please what is going wrong.

1 Like

The Yeelight 1s has a faulty firmware (2.0.6_0024). They basically released a firmware with a bug. If you have this firmware then this is your issue.I reported this issue like 1 month ago and yeelight just ignores it. At this point i am not sure if this is fixable with a firmware update or it permanently destroyed the bulb.

1 Like

My bulb is still unusable. I still can’t connect it to the server after reset.
@Yeelight stuff:
Is it possible to downgrade the faulty firmware? Will this issue ever be fixed?
I spend a money on your bulb and got a piece of plastic that does not work.

1 Like

No updates, no help, no answers. Excellent “support” from yeelight.

We are very sorry to hear that. Because of The Chinese new year and the International epidemic,We return to work one after another now,Is this problem still there?

Hi DennisJu,
yes, the problem is still exist. I have tried to connect the bulb to the server many times but without success. I have tried different servers, different router, removed and installed yeelight app - no success.
It’s always the same: Reset the bulb. After reset of the bulb the yeelight app can connect to the bulb, then it tries to connect to the server. The bulb flashing quickly and the yeelight app shows “Updating connection status, Just a sec…”. The connection status goes to 70% then the bulb flashing slowly and the connection status goes slowly to 100%. After that the app shows “Connection timed out” error and the bulb still flashing slowly.

I’ve also tried this method : Connection timeout issue
But it doesn’t work for me. I can’t connect the bulb to the server with yeelight account with the same issue.