Crystal Pendant Light went offline

I updated the firmware of it then it went offline.I have restarted it but is no use. Anyone know how to solve it?

could you please give me your mi id?


I have the same problem. With new firmware I can’t control the light. Please help.


Please provide the router model so that we can confirm if it is a wifi compatibility issue.

router name and type
innbox F60
v 2.0

If the router has some advanced settings like firewalls, plugins, etc., try turning off these additional features.

Any fresh ideas how I can solve my problems?

Put it to trash. Very Sad.
Crappy product,
crappy support from yeelight. Just see: Problems with Crystal Pendant Light and firmware 2.0.6_0042
Don´t buy.

It is a bit late now. :frowning:
It worked fine with the old firmware. Now I can’t get the control any more. Not sure if it is a thing of german server.

Hi, Can you try with a mobile hotspot instead of the router wifi, so we can judge whether it is a router compatibility issue。

I have tried that and it didn’t work. The phone connects to the light and starts installing the software. At about 45% of the process the connection brakes.

What should I do?

What else can I do?

Are you sure the device has been reset successfully? If so, the light will blink to notice.

It did. The problem is that it can’t connect. The process starts and the mobile shows the progress till 50% than the connection breaks.

Try it in mi home app. Switch server to China mainland.

My lamp seemed dead. Wasn’t able to reset it at all. Tried over 20 times. Somehow I got lucky. Maby the above suggestion helps u.