Mi gateway on Singapore server


#633

Oh yes your are right, added the mi home account on google home, i see all yeelight, air purifier, but not the plugs.
Can’t try it now since not at home…
Amazing news !! thanks for sharing


#634

the plugs are linked with wifi, not the zigbee


#635

Thats nice for Google Home users. I also remind that there is a similar skill for alexa many weeks now.
But since you say “I think it is no longer necessary to have the devices in singapure” I need to remind you again that the main reason most of us want to stop using the China server is NOT the Google home or the Amazon Alexa! this can be achieved with many ways (either official or third party) and as i said there is already an official alexa skill for mi home that works some time now and supports the same devices as Google home from what i remember.

The main reason we want to leave is because China server is SLOW and buggy especially for us in Europe!
Its exactly because it is slow that this alexa skill isnt working that great (not 100% success as a user confirmed) and why the same thing will happen with the Google home. So i think it IS necessary to find a good way to take our devices to a faster server (either Singapore or even better European server).


#636

I just tried integration with google home. I’m on the Chinese server and it really works all very well without any lag! already a few days the Chinese servers are working really fast, at the opening of the application all the devices are updated within 2 seconds. I inform you that it is necessary to tell google home “synchronize devices” after having associated the mihome account with google assistant. I almost forgot, for those who still do not know, I write from Italy. now I’m waiting for the integration with all the other devices (I can think of the smart socket, hoping it will become compatible, I’m talking about the previous zigbee socket, not the last model just released). finally, without too many tricks you can integrate everything to google home for voice control.

EDIT. I do not know if it is a limitation of integration with mihome, but I can not change the color of the lamps. at least we can turn them on and off, it’s a great step forward.


#637

It’s a very good news, just IFTTT is still missing on China server :wink:


#638

If they made any changes to the China server itself and it is now faster then this is great news.
The fact that the China server was so slow (and IT WAS) was always the excuse from yeelight team for not implementing the alexa, google home support over there (although the real reason was the policy and we all knew).

Someone can also try again the alexa skill on china server in order to inform us if things are better now.


#639

I am still on China server. For me, sometimes it’s fast and sometimes it’s slow. Like 1-2 second lag. How is the speed now that you moved to Singapore server?


#640

Its fine, not instant but almost… its almost everytime within a second (turn lamps on/off etc).
Not having the strange sudden delays i had in China anymore (a few times waiting many seconds)


#641

For me the main reason to move to Singapore server was to try google assistant. Singapore server is faster and more stable than Mainland China and it’s clearly noticeable when you load an ip camera.Lights was not a problem for me.
Anyway, I linked mi home with google assistant but I can see no devices. I also unlinked the yeelight account (it’s the same id) and didn’t help.


#642

Finally! I was really gutted when they made it available for Amazon Alexa since I just trade it with Google Home.

& Yes China servers is very slow for the last couple of months for me & it still be better if Singapore support all these Xiaomi devices.

Any news on when will the Yeelight 2nd gen version deploy on Singapore servers tho?


#643

Well I think a fair share of people who regulary checking this thread were also waiting for the Google Assistant, Amazon Alexa, Homekit & Xiaomi integration.

Yes, we need want to move our things to Singapore server but WE need as much information as we can & keep being updated on every move that Xiaomi take regardless the servers Region.


#644

Did you try this. It help me. once translated in french :slight_smile:


#645

Sure I did. If only xiaomi mi home account is connected with Google I get message “syncing unavailable for Assistant” . If both yeelight and mi home are connected then it’s only syncing yeelight actions.
Don’t forget, I am on Singapore server


#646

maybe it depends on the Singapore server trick you’ve set up. maybe the fact of confusing the application between Chinese and Singapore servers does not allow you to associate mihome with Google home! In any case with the chinese server I can only detect the bulbs in Google assistant And you can not change the color of light bulbs. Only on, off and brightness. In my case, Smart socket (I have the wifi and zigbee version) It is not recognized in Google home. Does anyone confirm?


#647

you may be right. I am ok with yeelight actions at the moment as I don’t have bedside lamp and smart plugs.
Does anybody know what is the product referred as “Mi color bulb”? i


#648

I’ve been following the thread for months but finally created an account to post today.
I was so excited to try the new GH x Mi Home integration but then realised when you link GH and Mi Home account, it only imports the lights but not the scenes (as opposed to Yeelight app which brings all the scene to GH as well) and therefore you can’t say stuff light ‘Hey google activate movie time’ which sucks.
I’ll keep following this thread and looking forward to a day where everything works together seamlessly :frowning:


#649

I confirm you, from people who have tried this new integration, that the first generation of xiaomi Smart socket (wifi only) It’s fully functional with Google home voice commands. I have the second generation (wifi and zigbee) and the support is not present yet


#650

Hi guys! SO, been reading all the posts and tried the “trick” to get my Gateway on the Singapore server. Does not work, tried about 30 times the last 2 days. Can see it (along with a bunch of other things connected to it) but when trying to access it I get the usual “failed to initialize device”.

Any ideas?

One question: When you write “logg in/out”, I never have to actually log in and out on my iPhone, I just have to change servers.

Please help! Everything works on the China server BUT I don’t undertand Chinese and the Roborock vacuum cleaner doesn’t connect properly.

Cheers


#651

You said the magic word, iPhone. This trick is only for android devices. Never heard anyone with iPhone do this.
On Android devices when you change from one server to another you get disconnected and you have to enter your credentials or let Google do this. I don’t know what happens on iOS


#652

Aha, bummer.

What about doing everything through HA via Rasb Pi. Can I skip all these steps?