Mi gateway on Singapore server


#613

Thank you to psybill and stormdreamer! It works!
This is what I did.

  1. Clear Cache of Mi Home App.
  2. Log into China Mainland
  3. Click Add Device Manually
  4. Select Gateway and Reset the device
  5. Once you’ve reset successfully you will be asked for your wifi ssid and password.
  6. Do not enter wifi id and password yet! You will trick the gateway device in staying on wifi pairing mode by quickly
    logging into Singapore Server as quickly as possible. (Profile>Region>Singapore)
    If done correctly, you will see a red dot on the upper right corner which means it has detected a new device.
  7. Click on the new device and you can now enter your wifi ssid and password.
  8. Now it will try to initialize the device but will be stuck at 90%, dont worry just cancel that. You think that the pairing has
    failed but the Mi home app is just hiding the gateway by now. You can also check if the pairing is successful if the
    zigbee sensors are now showing up on the app.
  9. Now clear the cache again and switch into the China Mainland Server but right after you sign in with your Mi Account
    quickly switch back to Singapore Server as quickly as possible.
  10. You can now see the gateway and enter its interface!

Gateway has latest firmware (updated in china mainland server)
Mi Home App lastest update


#614

Thanks a lot ! With this final step I can finally see my gateway and all the sensors !


#615

I tried this method with the european server, but it doesn’t work (yet I hope…) : I see no gateway or sensors at the final step. Fortunately, no problem with the singapor server after my failed test.

Thanks again Stormdreamer, Psybill and Tatchoni !


#616

many thanks!!!


#617

Nice! Guys can you test if you can arm the gateway and be triggered by the doow window sensor? mine doesnt work


#618

Glad to see that more people made their gateways work on Singapore server. Shame that we still can’t use Europe server.
@tatchoni alarm works fine for me. What I’ve noticed so far is that none of the devices I checked to trigger the alarm when I first set it up are now checked. It works though. Are there any checked devices on trigger menu for you?
You also said that your gateway is on the latest firmware, mine is not.

Has any body tried to enable password and fingerprint on security settings of the gateway? I have both enabled but they don’t work. I can enter in the gateway without ask me for password or fingerprint authentication…


#619

doesnt work for me unfortunately. have tried all sorts of methods.
problem is gateway remains invisible at step #10.


#620

That also happens to me. After I checked the device triggers they will become unchecked when i return to the trigger setting page. The other triggers work like body sensor and switch, they can turn on the alarm but no luck with the door sensor.


#621

Dont lose hope, i just tried it with my wifes phone huawei p10 android, and it also worked. You just need to be very quick on step 9. I mean really quick, after you typed login details and hit enter your next action is to change to singapore server (profile>settimg>region>singapore). Then you must Quickly sign in your Mi account details.


#622

I have both mi door sensors, aqara door sensors and one mi human body sensor and all of them working fine with the alarm. are you sure that the sensor is connected to the gateway? what about battery? You can try to reset the sensor and add it again. you can also try to create another scene other than alarm to see if the sensor works


#623

I managed to do everything and just like you suggested and everything is working.

I also have a mi remote and a dafang 1080, 360° cam. I managed to add both of them but unfortunately as you say I can’t open the pages of both this items so I can’t use them. I think that this is due to the fact that singapore sever won’t let download plugins for sensors / items that are not supported.

I think that one workaround could be preloading the plugins into mi home app, but I am not able to do this. Any ideas?


#624

I’ve also been trying to change to Singapore today, but I haven’t succeeded. Maybe I’m not quick enough, I don’t know. I did succeed however to completely confuse my gateway (v2) on the China mainland server. At first it would turn green every time a sensor triggered… Then after endlessly resetting and re-adding it wouldnt respond to anything anymore… I eventually managed to get it to act normal again, but I now have to redo all my buttons, switches and automations. I think I’ll wait till Singapore (or Europe!) is stable enough… I need my lighting to work :o) Thanks for the tips though.


#625

Yes it is working with the gateway like triggering the gateway light and the doorbell, it is only the alarm that is not working.


#626

i’m using password manager to help auto login (instead of typing in ID and pw manually). it’s already as fast as can be…
i’m going to have another go…


#627

Folowong above steps, I still have a problem, my gateway still wont appear at step 10, and when I am going back to mainland server, I cant add my gateway either, now it’s useless along with my sensors. I have tried many ways…but still failed, any idea?


#628

I have finally got it to work, by clearing the cache, logged in to China server and did a fast login to Singapore server.
Everything works except the IR remote controller, I can add it but not enter to its screen


#629

Your post reminds me when Mi Home and plugins were in Chinese language and people looking for a way to translate the app and the plugins. It also gave me an idea to try something, unfortunately I had no luck with Dafang camera.
The process of course needs root access on android devices. What I did was to root a Nexus 7 tablet that I don’t use any more, connect to Mainland China server and setup the camera. I then took the Dafang camera plugin and some related files I found in Mi Home folder and saved them to another folder of my tablet. Then I switch to Singapore server with the trick and setup the camera on Singapore server. Finally, I moved the files back to Mi Home folder and changed the attributes in files and folders. As I said it didn’t work, at least I tried.


#630

Good morning and good news: You can now associate the account my home to google home, all the devices (plugs and bulbs) that you have in china, singapure are associated with google home, with this I think it is no longer necessary to have the devices in singapure


#631

Just tried (with China server) and it doesn’t work.


#632

All the devices? Any Aqara devices? I can’t see anything on mine