Mi gateway on Singapore server


#592

Psybill, glad you got it working. The direct/quick change between servers was always the trick to at least see all the devices but probably most people dont follow that step correctly (thats why some people succeeded and some not in the past). Hopefully more people will manage to do it. But seeing all the devices is the easy part. The difficult part after that is adding the gateway successfully without initialization errors. For some this works right way and for some takes a few tries with the steps described in the past (out of ac power, reset again and then add again etc).
Its a good thing that you found that the same thing can be done for the European server (at least for the device list)!
I wish though that someone could confirm that the gateway also works for Europe like in Singapore since i cannot risk setting up everything in Europe again.

endriugeek, you wont literally loose what you have set up in China BUT you wont find your settings and automations in Singapore since servers are separated (only if you login in China and add the gateway there you will get your old settings back) :slight_smile: So yes you will have to add the gateway in Singapore again and also all the automations (the fact that you will see all the devices in the list doesn’t mean that you will have an easy time adding the gateway… seeing all the devices is the easy part of the process as i said…)

The key point is… PATIENCE!


#593

I opened up my mi home this morning and got this message. I wonder if this is a quick way to change region without losing any previous settings? Probably not since it mentioned that “regional data are independent” I didn’t try it as I wasn’t prepared


#594

Mi home updated to 5.1.35 yesterday but i dont see such a message when i open it… The funny thing is that this update was received to my tablet but in my phone the version is still 5.1.30 and it says that it is up to date :slight_smile:


#595

After updating to 5.1.35 on Android I could see all devices on the Singapore server.
Adding my devices (Mi Control Hub, Mi Smart Air Conditioner Controller, 1080P camera) worked without problems and could also be used after installing (with the exception of the camera).

Because I couldn’t load the camera after installing, I made the mistake and deleted the app data in Android. After restarting Mi Home, I couldn’t see the newly installed devices anymore (only my Bedside Lamp remained) and the list of available devices reduced to a smaller number again. :frowning:


#596

There is a new Aqara skills available on Amazon Alexa guess they rolling things out for the Q2 release.

But people said they can’t create an account for Aqara yet.


#597

That skill exists many weeks now and it is actually useless (at least for now)…


#598

Singapur server still doesn’t support the Gateway. None of the about hacks work.
Tried on the latest Mihome version + Gateway firmware. Always getting connection timeout.
Maybe it is a server issue that depends on the client’s region


#599

It is working for me. used @psybill howto and everything works now. Now I am on Singapore server with gateway and all sensors and using both - buttons, cube and Google home for switching and setting brightness on my bulbs.


#600

I think Aqara will update that skill or create a new one, because they said they will add Alexa support by Q4 2018.


#601

For those of you who successfully switched to the singapore server, does the mi IR remote also work on the singapore server? and if so, is it in english?


#602

Hi all, I have been following the thread for a little while and wanted to add my experiences so far.

I have been able to add the HUB using the Singapore server, but as with all the other “new” servers, it does not load the gateway’s interface. I keep getting the same error message as most of you have been experiencing. I have been able to add several of the Xiaomi child devices (Mi switch and sensors) and could set up Automation scenes. (Although it is quite limited, as you can not set up the home alarm triggers for example, because you will need to get in the interface.)

The Aqara devices currently don’t show up in the devices list on these servers, however, I was thinking it may be possible to add the Aqara child devices through the HUB’s interface? Well… I obviously can’t try that out as I can’t access it.

Another reason for it not functioning, I though of, could perhaps be because the firmware on my gateway is newer than the Singapore server is expecting? (I had that installed with the latest firmware on China mainland recently…)

I also do think Xiaomi is just experimenting with these new servers, possibly for upcoming international rollouts. (As I do see the smart plugs on those servers having new connectors, for example.) This might be an indication that Xiaomi is just giving a handful of test users in those areas access to the devices? (Not entirely sure though, but it could mean those devices will get supported when the products will launch in these territories?)

*To back that, you can’t buy the smart home set, or gateway, in Singapore through Xiaomi right now. Could that indicate that they might, soon…?

I will keep following this thread, and will continue to do some experiments with these servers on my end as well.


#604

Xiaomify, do you know any specific forum for Aqara products?


#605

Maybe you can ask Lumi for us since you got better connections with them. Some of us can see all the Aqara devices on the Singapore Server, some cant. Yeah I hope this is not “official” yet and all these is just the testing stage.

Btw what “smart plugs with new connectors” are you talking about? Any pics?


#606


#607

Mi Home 5.1.38 is now available for me on the Play Store.
A warning about new privacy policy and GDPR appears when you open the app for the first time, but nothing else has changed. No new devices on Europe or Singapore Server available to add…


#608

“Optimize user experience of overseas server”


#609

i am on china server and got this play store update as well. Like what you mentioned nothing changes, and in fact made something worst. Some of my automation rules which uses, the motion sensor and temperature sensor is now facing problem.

there is now a red exclamation mark besides these rules, and when clicked it will show a message saying: “Abnormal in the sync from cloud to local automation, please retry”

i will not work no matter how many times i retied and if i try to recreate the same rules, it will not let me confirm at the last step (OK button greyed out).

Anyone facing similar problem? So far i noticed this only happens on both of the sensors mentioned above. Others seems fine so far.


#610

@iluvyeelight sorry I can’t help you on this because I have set up my devices on Singapore server.

I think that I have something very important to report though:
Till now, people who have successfully connected the gateway to Singapore Server were able to see and control the gateway and other unsupported devices only from the device they used to setup Singapore Server. Even if you tried to login to Singapore Server with the “well known trick” and you could see the full list of available to add devices, your devices that are not normally supported by Singapore server were not visible on Mi Home app.
I am sure that I have tried to login to Singapore server from other devices too many times in the past and I always could see only the supported devices. I tried once again today and BOOM, all my setup devices are there and working like they do in my smartphone.
Gateway: fully fanctional
Aqara A/C companion: can enter menu but there is no a/c device. I can’t test it any further because I can’t add device from a chromebook.
Aqara Switches, Sensors: can enter menu, see logs etc
Dafang camera: connected but not working
Yeelight v2: connected, can not enter menu, working in automation.


#611

Not yet that I know of, but I was thinking to perhaps start a forum on the Xiaomify site


#612

Yes since nothing is officially released at this point theres not much that I know of. I do know that it is a matter of just weeks, maybe months at the latest before we will get answers.
You know which channel will bring the news :wink:

I am referring to the Mi smart plugs that you can add on the Singapore or US servers. Looking at their image, its a different connector :wink:
I just took a screenshot of it though