Lamp doesn't turn on immediately when using the physical button


#1

I have a new Yeelight Mijia bedside lamp. It has a major issue, basically, when I try to turn it on using the physical button on top of the lamp, 7 times out of 10 it doesn’t turn on and I have to press the button multiple times to get it to turn on. There doesn’t seem to be any logic to this behavior, also, I tried to reset it and not connect it to wifi but it still fails to turn on most times. After a first successful turn on, it works just fine for a while and turns on/off normally for a while, but then it will have the problem again.

Lamp is using the latest firmware.

Please help me fix this issue, it’s really annoying and I’m considering returning the lamp for this.


#2

Could you try the mode button (the little one)?


#3

What do you mean? By the way, if seems like sometimes it takes multiple presses even to turn it off. It doesn’t feel like a hardware problem, more like some kinda bug with the software, it probably tries to contact the server before turning on or something stupid like that.

This is extremely annoying because turning on and off is like the basic function of any electronic device, I dont even care about all the cool stuff this lamp can do when it doesn’t even respond to the power button most of the time. I’m seriously tempted to just get rid of it, this is just stupid, troubleshooting a freaking power button on a bedside lamp.


#4

If you are here just to show your anger, then please return the lamp and get your money back.
If you want to solve the issue or help us solve the issue, please help us do some debugging.


#5

Sorry, I got super frustrated this morning.

Please explain what you mean by trying the mode button. From what I can tell, that button works just fine. Unfortunately it doesn’t seem like it can be used to turn on the lamp.


#6

If the mode button (the little one) can control the lamp, then it means the firmware is still working. When you press the power button, is your hand touching the touch panel or very very close to the touch panel?
There is a firmware bug we just found today: if you press the power button while touching the panel, the press event will be ignored by the firmware. We are working on the fix now.


#7

Thank you for this info. I honestly didn’t notice a difference if I was inadvertently touching the touch panel or not. I will try to not touch the panel at all for now when I’m trying to turn on the lamp using the button. Hopefully this is the reason and you will release the fix soon, it’s really annoying when you need to quickly get some light while in bed and the lamp is uncooperative, forcing you to get out of bed to turn on the main lights.


#8

A fix for what? This is one of the most absurd thing I´ve ever read on this forum…


#9

It seems like the power button doesn’t respond properly if you touch the touch panel while also pressing it. Are you having this issue as well or is yours working fine?

I can’t tell if my issue with the power button is related to this bug though, because I can’t test right now, but I wouldn’t rule out the fact I was accidentally touching the touch panel as well when the power button wasn’t responding in my case.


#10

I tested it a few times, it seems like it turns on just fine if you don’t even touch the very edge of the touch pad while pushing the button, but then again it doesn’t drop the button press every single time, that’s why I had no idea what was going on.

The mystery is solved then, thank you for the prompt response weiwei. Eagerly awaiting the firmware update.


#11

Hi, I can confirm this problem. It happens with my bedside lamps as well.


#12

Any good news on when the firmware update will happen?


#13

So i have this Problem too. When you roll out the new Firmware? :thinking:


#14

Any chance of getting this firmware update any time soon? It’s extremely annoying to tap away at the button when you need a light quickly and nothing happens.


#15

Already in testing. Stay tuned!


#16

Could you provider your MI ID, we can add you in beta test to update firmware to see if it works for you. Thanks!


#17

1776185330

Thank you, I hope it works.


#18

Done, please have a try.


#19

I downloaded the update which installed successfully. It seems to work much better than before, no dropped inputs and the lamp turn on and off perfectly so far, but maybe it’s too early to tell. I’ll let you know if I notice anything weird.


#20

Hello,

based in germany i would like to participate in the beta test becouse I too experience the exact same issues with both of my bedside lamps while trying to power it on via physical button.
Mi ID: 1736698699