Issues Pairing my Yeelight Bulb WHITE


#1

Hi there,

I am having huge issues with my Yeelight LED WHITE bulb. I have managed to pair the bulb successfully in the past and even integrate it with Echo & IFTTT, but often it goes offline and wont work again until i re-add it. As if this wasn’t annoying enough, the re-adding procedure is becoming increasingly frustrating. I have followed the correct steps millions of times but with no success:

  • Reset the bulb (on and off 5 times)
  • Launch Yeelight APP
  • Add Device, input my household WiFi password

The Yeelight App then starts it’s configurations by switching back to my home WiFi, but then remains stuck on 25% ‘iPhone is connecting Wi-Fi’ for over 15 minutes and then simply gives me a big red cross as be below screenshot.

The Yeelight Bulb btw, is is visible on my router and if I Ping ot.io.mi.com everything checks out correctly. My Mi Account is 1648991941.

Looking forward ot hearing a solution to this issue. Many thanks in advanced!
Gio


#2

Could you try logout your account and then re-login?


#3

Thank you for the prompt reply.

I already tried in the past logging out and back in the Yeelight App and then adding a new device but I have every time the same identical issue. Stuck on 25% and then after several minutes I get the big Red Cross :cry:

I have also deleted the App and reinstalled it, reset my WiFi router, reset my iPhone and even try the bulb in different rooms…no matter what I do the result is always the same!


#4

Do you know MiHome app? Could you try add device through MiHome app?


#5

I tried with the Mi Home App (which by the way supports only the colour LED not the WHITE that i have) and it does reach 100% but then asks to reset my bulb.

I tried doing that but every time it reaches 100% it goes back to asking me to reset the bulb.


#6

Do you have an Android phone? You can try again with Yeelight app. Any problem, let us know.


#7

Do you have any other Yeelight lights? You can try them again.Make sure your router and iPhone are both connecting to the internet.Many thanks.


#8

No, I have an iPhone. I have tried with the Yeelight App and nothing works.

What do you mean any problem let us know. The entire post is about the same issue to which there was no solution provided!


#9

No I dont have other Yeelights. Of course the iPhone and router are connecting to the internet, I wouldnt have contacted you before checking absolutely everything.


#10

Could you change your server to China Mainland and add the device? Let’s first make sure the bulb is not breaking.


#11

Sorry to bother you.You can try what Weiwei said. I will contact server colleague to check the further reason and give you a solution tomorrow at the latest.


#12

Hi,

I tried connecting to the Mainland China Server, and then again with the Singapore one. Tried on the Yeelight App, Mi Home App, tried logging out and back in. I even deleted the apps and reinstalled them after resetting both my iPjone and Router…absolutely nothing!

The Bulb works and turns on fine but there is no way to add it to the app in order to control it!

Hope you can help!


#13

Have you got wechat or any other instant message applications?More convenient to contact you.


#14

Yes I do. My WeChat ID is giocacchione.

Many thanks in advanced!


#15

You are so nice.I have already added you. My WeChat ID is ball-bro.Waiting for you here.


#16

Did you ever get this problem solved? I’m having exactly the same issues. My bulb is connected to my router(I can see it on my connected devices) however I’m getting constantly connection time out when using yeelight or mihome app on 100%.


#17

Could you logout and re-login your account?


#18

Yes, multiple times. I’ve reinstalled mihome multiple times, as well.
I can ping ot.io.mi.com, no problem.
My xID is 1609630865


#19

Having the same issue. My two Yeelight RGB bulbs were working fine until yesterday, but I moved to a new apartment today so I reset them to connect to the new network. Using Yeelight app, it’s stuck on 25% “iPhone is connecting Wi-Fi”. Then I get the same “iPhone is connecting server” error as shown above. Using Mi Home app doesn’t work either. Tried both Singapore and Chine locals, although I need to use the Singapore one because of IFTTT. Both bulbs have the same issue, which leds me to believe the problem is server-side.


#20

Please check if your bulb is present in the DHCP client list, try to ping it to see if it has connected to the router successfully.