Can't reset/connect color bulb - Yeelight app searches, doesn't find device


#1

A couple of days ago I noticed my color bulb skipped a routine. Yesterday I decided to manually check it out, and saw the Yeelight app considered it offline. I am having problems resetting it. Here’s what I did.

  • tried to reset it via on/off x5: the bulb would endlessly flash colors and no white.
  • tried resetting again. same as above.
  • tried to unpair it: I can’t find how to unpair in the new 3.0 version of the app (BTW: where is it?), so I try using MiHome.
  • unpair in MiHome app. Try to pair it again - can’t be found.
  • tried reset a few times, but the bulb still flashed colors, and didn’t stop on white.
  • i figured maybe it was a server problem (Singapore), so waited a day to retry.
  • today i try to reset. this time it does stop at white after flashing colors, but still can’t find the device on Yeelight or MiHome apps.

I saw someone else not being able to connect (http://forum.yeelight.com/t/unable-to-connect-light-anymore/2036/13).


#2

To follow up, I was able to reset/connect my Yeelight yesterday, but within a few hours the bulb was shown to be “offline” again. What is odd is that I also have a white bulb, which is working consistently.


#3

While I wait for some feedback, let me add more info. Tried again today to reset, but it stops halfway through binding. I tried to do a manual wifi connection, but although I see the yeelight wifi-spot, it has excellant strength, it just will not connect (again, I’m using the Singapore server, which was suggested a long time ago as being the more reliable one).

Any ideas?


#4

Any update?

Could you see hotspots named with like “yeelink-light-**” in your system wifi settings after reset the bulb?


#5

Yes, I tried the manual connection and I couldn’t stay connected to the yeelink wifi hotspot. I also tried to manually “forget” the connect, reset, and try again but nothing worked.

I’m trying once again right now, and I get somewhere around 80-90% connection (even 100% a couple of times!) and then it fails and says “connection timed out”.

Like I said, the odd thing is I don’t get any drops / disconnections from my white bulb also on the same Singapore server. Since it doesn’t seem to be a server problem (or is it?) could it be the new firmware update you pushed a couple of days ago?


#6

Do you have other Yeelight wifi devices? Do they work?

It seems this is a network issue, could you post the ping result of “sg.ot.io.mi.com” or “ot.io.mi.com”?

Or do you have another phone? You can setup a hotspot with it and try to connect the bulb to it.


#7

Thanks, @dingyichen Yes, like I wrote above my white bulb has no problems and tried using both Yeelight and MiHome apps (please read previous comments). I just tried using another device and still nothing, but like I said, I have no problems with my white bulb.

Here’s the ping:

C:\WINDOWS\system32>ping sg.ot.io.mi.com

Pinging sg.ot.io.mi.com [52.220.159.77] with 32 bytes of data:
Reply from 52.220.159.77: bytes=32 time=288ms TTL=43
Reply from 52.220.159.77: bytes=32 time=286ms TTL=43
Reply from 52.220.159.77: bytes=32 time=284ms TTL=43
Reply from 52.220.159.77: bytes=32 time=286ms TTL=43

Ping statistics for 52.220.159.77:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 284ms, Maximum = 288ms, Average = 286ms

ot.io.mi.com” resulted in time out.


#8

Still having this problem after a week. Could I get a little help, please?


#9

sorry for late response, last week was national holiday.

Do you have another phone? Could try to setup a hotspot and connect the bulb through that?
Or could you check your router’s DHCP list and see if the bulb has connected to the router successfully?


#10

Hello!! I have 4 yeelight RGB bulbs on ceiling lamp and exactly the same problem with 1 bulb! It’s hotter than the others, difficult to reset (flash colors but no stop white) and keeps disconnecting from wifi router! It seems a malfunction bulb!


#11

I forgot to mention that the bulb disconnects when getting hot and it has to become cold to reset and reconnect again.It’s completely useless! By the way, i wonder if these malfunction bulbs belongs to the same lot as i receive it very recently from Banggood!?


#12

Hi @weiwei thanks for your reply (and hopefully you all got some much deserved time off!). Yes, please take a look at the whole thread to see the steps I took as well as other info which might be of use. Seems like I’m not alone on this.

And to add to all the info, I just tried to reset/reconnect right now. It tries to “update connection” but times out again at 99%.


#13

Swipe the device card left, you can unpair a device by the delete icon.

Will take a look at it.


#14

I just tried to ping both ot.io.mi.com and sg.ot.io.mi.com, and everything came back happy now. Tried to reset my bulb and it worked. Hopefully it doesn’t disconnect again.

I guess your servers decided to go on holiday too!! Glad everything is up and running again. Thanks again.

EDIT: I was able to connect, but after a couple of minutes it shows as OFFLINE in the app, even though I was able to turn it on - and in fact it’s still turned on. Why? Again, I have two bulbs. The white one is working fine, but the colored one is having all these problems.


#15

Please PM your xiaomi ID. I will help to check.


#16

What do you mean you were able to turn it on? Turn it on from app or from power switch?


#17

I was able to reset, connect the bulb and control it from the Yeelight app. I changed the color from the app, and soon after the light still on, I wanted to turn it off from the app and it shows as offline.

I’ll PM you my Xiaomi ID. Thanks.


#18

When the bulb shows offline in app, means the bulb was disconnected from cloud, has nothing to do with it was on or off.


#19

So, if the bulb was on and connected to the cloud, how did it get automatically disconnected after a couple of minutes - and how do I connect it again and keep it connected so I can use it from the app? That’s my whole problem.


#20

Same problem here! For testing i reset all my 4 yeelight color bulbs and connect them to the cloud in several different order and it’s always the same bulb that keeps disconnecting when getting hot after some minutes working ok…