Can't connect to Mi Desk Lamp

I got same issues. In my case the lamp was in router’s DHCP list. But i can’t change DNS to Google, because will cannot access to internet.

What’s your xiaomi account?

Please refer to the link to see if you are the case:

Thanks for feedback. My xiaomi account is: 6178821096.

I will try approach your note above tonight. Thanks

Thanks for support @dingyichen.
After login with your account and upgrade firmware, i re-login my account and try connect again. It’s work fine.

I have the same issue. I can see my lamp connected to the router with the name: ESP_559DDE, which changes after I put the lamp out of power and back in to: yeelink-light-lamp1-miio71556011. I can’t see any setting on my router which would block the lamp connection. My ID number: 6179927436

Please refer to the topic:

Sorry I didn’t saw your earlier answer. Thank you for helping, after the firmware update I am able to connect to the lamp now.

Hi. I’ve the same problem.
New lamp in the dhcp list.
Not connection in mi home. Connection timeout.
Help me.
Sorry for English

Please refer to Connection timeout issue

Hello Yeelight, My Mi Desk Lamp is no longer connecting to Mi Home. I already tried to reset it twice to no avail. It still shows Device Offline.

Can you contact me via I’d really appreciate it.

Dears, i have the same issue, cannot connect to the internet. My ID is 6267326983

Please refer to:

I tried. Initially was logged, updated, perfectly worked. In the morning back to hell, the lamp was not any more on the Yeelight app. Tried again to log with lixin account but the connection is stops to a “Connection timeout” message!! I didn’t succeeded to log any more :(.

Android or ios of Yeelight do you use? Have you update firmware with lixin’s account? If yes, it should be work with yours too.

Not even with lixin account it cannot be connected.
I succeeded only when I created a hotspot from a mobile phone, with the same SSID and pass as my home wifi network. This was the solution to connect to the lamp and updated firmware.
Still, if I pull-off the lamp from power switch or I reset the wifi router, it tooks a lot until the lamp is back on the network.
It is verry difficult and give me emotions, so I do not reccomend to buy.
I had thinking to buy a colorful led bulb for my daughter, but now I am thinking twice, what if it is works with the same difficulties?

I also have the same issue. The lamp cannot connect. What is yeelight wifi password?

I can’t login in that account.

I logged in with account 2410552805. Firmware version of my lamp (My LED Desk Lamp 1S) was 2.0.6_0007 and it said no updates available. Does it need to whitelisted to get updates ?
I still cannot add the lamp in my account, in my region(India). I have already set the dhcp server to Please help.

My ID 5308305778.

I have got different problem I can’t restart lamp I press the button but nothing happens. What can I do?

i can not see the wifi of this lamp (yeelink_lamp***)
please help me with this
mi acc: 1156059741