Cannot connect Yeelight Ceiling to wifi network


#1

hi, I have attempted over 10 times to attached this device to a wifi network. I have tried various different networks.

I currently use a Samsung Galaxy S5 (Android 6.0.1) with Yeelight App (version 2.3.09 ) and I’m based in the UK.

When attempting to add the device to my Yeelight app, the app will scan for wifi networks, I enter the password, then once the process reaches 100%, it will say “connection timeout”. The password is correct.

After each attempt I reset the device by power cycling 5 times.

The bluetooth remote controller works fine. Please can you assist.


#2

Which server did you choose? China Mainland or Singapore? Do you have other Yeelight WiFi devices that connect successfully?
Could you let us know your XiaoMi ID, so we can have a check on server side.
Also, please check whether your Ceiling has connected to the router successfully.


#3

Thank you for your reply, I have used the Singapore server. I currently have 2x Bedside lamps connected, but no other Yeelight wifi devices.

My xiaomi ID is : 1610831626

Also, the light has connected successfully, MAC: 286c07b336e7, I can also ping the IP address.


#4

Just checked with some backend guys, the ceiling is not yet online in Singapore server, so please connect to China Mainland server as a temporary solution, we will add the support as soon as possible.


#5

thank you for your help, all is working great now.


#6

Hi, any more news about the server in Singapore? Here from Germany the Singapore server reacts faster than Mainland China. By when do you think will the ceiling lamp be connectable from Singapore server? The lamp itself is really great!


#7

Should be available after next firmware update and app update. Please stay tuned.


#8

Already support connect Ceiling lamp to Singapore server, please update the latest version of Yeelight app and try again.


#9

My version is 2.3.09,distance of device to WiFi router is 3meters, still same error message. What can I do?
MI Home 4.0.11 is reacting same.
Andreas


#10

2.3.09 doesn’t support connect Ceiling lamp yet, please go to Google play to update the app to 2.3.12, which is the latest version.


#11

I have installed recommended version and connected to Singapore server. After 2 hours the device loses its connection and I have to reinstall it. It is not fun yet…


#12

You don’t have to reinstall it. When you see connection lost issue, please:

  1. Check if it still connects to your router.
  2. Check if your remote controller is working.
  3. Refresh the device list and see it you can see the device online.

#13

im having the same problem on connecting it to wifi. I have installed 4 yeelight in the same room, but only 3 get to connect to wifi and the other 1 left cant.

can i know if i can control this 4 lights with only 1 remote controller?


#14

Yes, pair the controller with your ceiling light one by one.


#15

Got same issue like @Paddler0
I’ve connect my ceiling lamp to singapure server and works fine. But after couple of minutes connection droped and looks like this

Only factory reset helps, but only for next couple of minutes :frowning:

  • Lamp is still connected to my wifi - I can see it on my router ui and ping.
  • Internet works fine. My Yeelight strip works in same network without any issues since couple of months.
  • My account id: 1662505809
  • Remote controller still works fine

#16

Your firmware is too old, I suspect it has some bugs that we already fixed (a DHCP issue). Please switch it back to China server and update the firmware or you can wait a week and we will release the new firmware on Singapore server.


#17

Hi Sebastian, my name is Andreas from Germany. I am a little bit struggling with the devices and installation via Singapore vs Mainland China. Are you interested in a call with me?


#18

Please connect to China mainland firstly, update the firmware and then you can connect it to Singapore. This is because the old firmware doesn’t support Singapore yet.


#19

@weiwei Thank you for quick help :slight_smile: . I have now upgraded the device. Hope it will resolve my problem. I’ll let you know when this bug still exists.


#20

Is a connection and control via gateway also with Singapore server possible?