Bulbs can't connect to new router (Connection Timed Out Error)


#1

Hello Everyone,

After reading an abundance of posts about connectivity issues of the yeelight bulbs i still can’t configure a solution to my problem.

As the titlle says, everything was working perfectly until i changed my router. With the new router i can’t connect my bulbs/ledstrip neither with the Yeelight application nor with the MiHome.

I have tried to reset the bulbs and the ledstrip a lot of times but nothing happend. After a reset, i connect to the Yeelight app, try to add a device, login in with my WiFi and when the process of adding the device begins normally. Everything goes ok up until 45%. Then my phone connects to the yeelink network and the percentage of completion counts very slowly until it reaches 99% and then i get the connection timed out error.

Router is set to 2.4GHz , i added to my DNS the 8.8.8.8, i have tested all servers (Singapore, China, US) on both apps, after a reset when i login to my router i can see the yeelight network in my DHCP, changed my new routers ssid and security to the same ones i was using with my old router still nothing! Even tryied to hotspot with another smartphone and connect to that instead of the router but again connection timed out.

What else can i do ? Is there any solution for this thing ?

Both Bulbs and ledstrip have the latest firmware update
Old router : ZyXEL VMG1312-B10D
New Router: ZTE ZXHN H168N

Ping Status that i get
PING sg.ot.io.mi.com (52.221.72.237): 56 data bytes
Reply from 52.221.72.237: bytes=56 ttl=50 time=416.4ms seq=0
Reply from 52.221.72.237: bytes=56 ttl=50 time=416.0ms seq=1
Reply from 52.221.72.237: bytes=56 ttl=50 time=416.1ms seq=2
Reply from 52.221.72.237: bytes=56 ttl=50 time=417.6ms seq=3

sg.ot.io.mi.com ping statistics —
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 416.0/416.5/417.6 ms


PING ot.io.mi.com (124.251.57.11): 56 data bytes
Reply from 124.251.57.11: bytes=56 ttl=41 time=416.0ms seq=0
Reply from 124.251.57.11: bytes=56 ttl=41 time=420.2ms seq=1
Reply from 124.251.57.11: bytes=56 ttl=41 time=419.6ms seq=2
Reply from 124.251.57.11: bytes=56 ttl=41 time=418.4ms seq=3

ot.io.mi.com ping statistics —
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 416.0/418.5/420.2 ms


#2

Please share your Xiaomi ID with us, we need to take a look at the logs. Could you change your old router and try?


#3

My Xiaomi ID is 1720216202.
I will try to connect my old router again today. As soon as I test it I will update you.


#4

Hello

I have the same problem since I changed the router to ZTE F660, led color bulb and xiaomi smart socket do not work.


#5

I changed to my old router again and the connection between the router and the bulbs accomplished successfully. Then using the same ssid and password in my WiFi i connected my new router and i was able to manage the bubls for about a week when suddenly all of them went offline again and since then i cant connect them to the app.


#6

For sure this is a ZTE router problem, it can help ZTE or Xiaomi. We will not do anything alone :slight_smile:

Dimitris: a good way, I have to try. edit: unfortunately it does not work with me :frowning:

Solved:


#7

For me this doesn’t work… I saw this post before opening this thread and tried these dns settings but still nothing! I continue to get the connection timed out error.


#8

@weiwei is there any solution to my bulbs constantly going offline? I don’t know what else to try in order to fix this problem.


#9

when your bulb goes offline, could you confirm that local connection is OK?


#10

BTW, could you check your router’s DHCP settings? Check the “lease time” and let us know.


#11

The lease time is set by deafult at 86400 sec. Should i change it ?
Right now both bulbs are offline and i dont see them in the DHCP list. The only one working at the moment is the ledstrip . Still getting the connection timed out error when trying to add bulbs in yeelight app.


#12

Please wait for 23 hours and see if the lightstrip will go offline. If yes, then it should be some compatibility issue between your router and the bulb’s DHCP implementation.


#13

I have the same Problem as the other people. Than i try to connect the bulbs with the Mi Home app. That works. With the Yeelight App i am not able to reach any of my 7 Bulbs. I do not know what to to. I tried anything. Greets Marian


#14

Mihome and Yeelight share the same cloud server, if you connect the bulb with Mihome, you can also get it from Yeelight. So please make sure you select the same server in both application.


#15

Yes. But the App Yeelight does not connect to the bulp. During connection my Mi6 connect WLan to the bulb. What can i do


#16

Your phone still connect to the AP of the bulb, so the bulb didn’t connect to your router. Which router do you have and do you have some special character for the password?


#17

Hello, Telekom Speedport Hybrid/ Huawei. Normal Password only numbers… to connect to mihome no problem, but i need the connection to the yeelight app, cause of third party settings. Both applications server: mainland china. Greets


#18

Mihome and Yeelight share the same server, so if you connect the bulb to Mihome, you can also get it from Yeelight, you don’t need to connect it again. Please make sure select the same server and use the same account with Mihome.


#19

I can not get a connection without reset the bulbs. Same Server…


#20

You don’t need to reset and connect it again if you have connect it with Mihome.