Bulb keeps going offline after a few days

Hi there!
I’ve got two Yeelight color bulbs in one lamp, one is working perfectly, but the other goes offline every couple of days and then needs to be reset. Kind of annoying. This bulb is also more difficult to set up, takes several attempts to establish a wifi connection. Is this a faulty bulb or is there anything I could do to solve the problem? Firmware is the same, server is Singapore, also already tried swapping the bulbs to no avail.
Any help would be appreciated. Thank you!

Please help do some tests.
When the bulb shows offline again, could you logon to your router and check if the bulb is still connecting to it (check the DHCP client list)? If you see the IP of the bulb, could you ping it to see if it’s accessible?

I just checked and the bulb is no longer in the client list.

Problem persists, after 9 days of working, bulb goes offline again, need to reset it or take it out and screw it back in to get it working again. Anything else I can do?

We have successfully reproduced this issue in our lab, chip vendor is looking at it. Will release firmware update once got fix.

I am having the same problem with mine… after 1 day i cannot get online have to reset and re-do the setup again… then continue to do every 1 day.

i also have the ceiling light which never has this problem.

On Singapore server.


Have you updated the firmware to the latest version? The new firmware should fix this issue already.

yes using latest.


What the brand of your router? Did you reboot your router everyday?

No didn’t reboot, i reboot some days ago to test if it fixes the problem but yeelight still need to add device every 1 or 2 days.

router is https://www.asus.com/au/Networking/RTAC3200/

I also make sure it only connecting to wifi 2.4Ghz

yeelight ceiling light dont have this problem… only the color bulb.

When you see the issue next time, could you login to router’s management portal and check if the bulb still connects to router (check DHCP list and then ping the bulb).

normally i can see in the DHCP list on my router but once i notice in app saying offline/refresh it does not show in the router DHCP list again until i add device again.

You don’t need to reset and add them again. Try to power on that device and check if it could restore back online next time.

I have tried that… sometime if i turn on manually by switch after 5min it will re-connect wirelessly and in app will show status… but this does not always work or convenient to do if need to remotely turn on light.

I have tried turning light on and off multiple times manully but still same only way is to re-add device to get online status.

Even if globe is powered on 24/7’s after sometime in app will show offline.

If you turn the bulb on and off five times in a row, the bulb will be reseted to factory default, all the user data including network config will be cleared. I don’t think that could help for your case, so please don’t do that next time.

The latest firmware update fixed couple potential issue that may cause occasional offline. With that fix, we can’t reproduce offline issue in our lab anymore.

What’s your dhcp lease duration config on your router?

I don’t turn off more than 3 or 4 times… if i want to reset i do it 5 times.

DHCP lease on router is default have not check but most likely 1day?

I have setup MAC and IP address bind so bulb always have same static ip.

the only problem happening with my color bulb not the LED ceiling light. I want to purchase another 2 but due to this problem i have not purchased… its annoying and if it continue will stop using the bulb.

Please change the dhcp lease duration as long as possible and then check if the problem still happen.

Hello, OP here again. I updated to the latest firmware version, things looked good at first, now the problem returned. It’s always the same bulb, the other one’s working flawlessly. It’s still in the client list of my router, and I can ping it. Before updtaing the firmware I could get it back online rather quickly by taking it out and screwing it back in, not working anymore now.

Please give me your xiaomi account. I will help to check.