Yeelight Striplight Connection Timed Out

Hi, do you have other wifi based devices?

Actually, I got no idea about the issue, it seems there’s something wrong when the strip try to connect to the cloud. I have mailed to xiaomi cloud engineer for help if there is a way to have a analysis.

Dear Andy,

This is not a solution. I need solution. I have imported this unit. It must work. Wifi based devices means?

My mobiles, laptops does work with the router.

Please provide solution on priority. Add me on Wechat with your engineer to solve my issue. I need to buy more units. I’m already stuck in 2 units. How can i handle 100 units.

Please provider your xiaomi account.

Same problem 5161288339

5164734300 is the account number . please help me on priority.

Hi, Could you have a try with below:

1、Get IP address with command “ping sg.ot.io.mi.com”, it is like “13.228.161.182” (Use sg.ot.io.mi.com for Singapore server, us.ot.io.mi.com for US server, de.ot.io.mi.com for Germany server and ot.io.mi.com for Mainland china server);
2、Setup a local DNS server with your PC (You can use tool of simple dns), add an “A record” with the IP address you get from Step 1 associate to “sg.ot.io.mi.com”;
3、Modify DNS server of your router to the dns server you have setup in Step 2;
4、Reset the bulb and try to connect again to see if it works.

Thanks,
Andy

@Satyamsaxena @brsrajan

we have found root cause of the issue, more information please refer to the page of

Sorry about the issue.

Thanks,
Andy

1 Like

Hi Andy,

I have the connection timeout issue with my MI desk lamp and the lixin@yeelink.net account works for me. However even after updating the lamp’s firmware my account still cannot register the lamp and the error is still connection timeout. I am currently using lixin@yeelink.net account but would like to be able to use my own account. Please help.

ID: 6151454787

Regards,
Wt

Thanks for you feedback.

Which server do you select in Yeelight application? And please try again and tell the time you tried with your account, we will check log to see what’s going on.

Hi Andy,

I am using the Singapore server and I tried it multiple times within the hour of my previous post

Hi,

Please refer to:

Thanks,
Andy

Hi Andy,

Works great now. Very thankful for your quick responses and help. Appreciate it!

Regards,
Wt

G’day Andy,

My account number is much less than that number, and all my Yeelight devices were successfully added to my Xiaomi “Mijia” app. Thanks so much for working on this and finding a fix for the Yeelight devices.

Now, even though all theYeelight devices connected fine, my Xiaomi MI Control Hub gateway device has the same issue as before - it gets an IP but cannot connect fully with the app. So I’ve now got my lights working, but no door sensors, occupancy sensors, temp/humidity sensors nor buttons to easily control the Yeelights.

Any ideas on how to get the gateway connected? (I also tried logging in with the lixin account and it had the same issue - failed at the same place.)

This trick onlys apply for Mi LED Desk lamp, this is a bug we found in last release. As for device of Mi Control Hub, I have no idea about it, I saw your post before about the issue. And you have tried ways I known but that doesn’t works. This is not made by Yeelight, maybe you can contact them who made Mi Control Hub for help.

Hi Yeelight Support,
Can you please help me connecting to Yeelight LED Striplight using Wifi?
I have already tried using [lixin@yeelink.net] Login to connect and update the software.
Nothing works, I am getting Timed Out Error each time.
Please help My ID is 615666442.

Thanks,
Jagdeep

[Connection timeout issue](See here as stated above)

Hello.
I have this same issue, connection time error. I try with hotspot 4g. I update lightstrip to latest firmware and its worked but after 10-15min lightstrip is disconnect and in yeelight app offline status. In my router I see lightstrip in DHCP. I have ten yeelight bulbs and all works correct but lightstrip not.
Please help.
Michael

Server: Mainland China
My ID: 1597911241

Thanks a lot for ‘excellent’ not helping… This is my last purchase of yeelight stuff. From my site its all works but from yeelight is not and support is not helping customers.

Hello, I also have the connection time out issue. I do see the strip in my router, can connect to it with my phone and have another one running without any issues. Can you please help?

Many thanks for your assistance.

ID: 6240671297

ID 6246599500

Can see the strip, it’s in the DHCP list. DNS set to 8.8.8.8 but not able to complete setup.

The lixin@yeelink.net password doesn’t work. Are you able to change it back?