Yeelight strip does not pair with my wifi


#1

Hi Yeelight team.
I cannot connect my yeelight strip to my app. But I have isolated it to some problem with my home wifi. (when I created hotspot on 1st phone and connected strip with 2nd phone it worked).

Do you have the list of potential settings which can influence connection? (e.g. special characters in wifi name or password, length of wifi name or password) I am happy to work debug with you :).

Few info from my side:
Mi Account: 1755620339
Tried pair with 4 apps and 2 systems: Yeelight iOS 3.1.10 (SE), Android 3.1.11 (S4), Mi Home iOS 4.7.1 (SE), Android 5.1.10 (s4)
Router: Comtrend
Security: WPA2-PSK
Wifi Name: TrojanSpy:Win32/Banker.ADN
Wifi Password Length: 13 characters
Note: other mi home smart gadgets (sensors, gateway, switch) works


#2

Which phone do you use to connect? Have you update firmware after your connect with hotspots?


#3

Hello,

Which phone do you use to connect?

I have used Samsung Galaxy A5 and iPhone SE. Versions of applications are in the post above.

Have you update firmware after your connect with hotspots?

No I did not update firmware because before pairing i have download the app for the first time and updated firmware to latest version. So after connecting there is nothing to update.


#4

Which phone do you use to setup the hotspot? As you can connect it successfully, I think the lamp is ok.

There is a known issue with Iphone when connect to light strip, so please try agin with your Android phone to connect.

You can refer to the link to check which step do you stuck?

Thanks!


#5

Hi,
sorry now I get your question. I have used Android phone as hotspot phone and connected with iphone. this worked even with iphone.

step 1 OK - I can see the lamp’s wifi
step 2 OK - I don’t have any special character in my pass, only numbers, uppercase and lowercase
step 3 not OK - I have problem with step 3, that i cannot see the lamp in the DHCP list. Based on your experiences do you know what setting can cause the lamp is not connected?
Note1: I have the router set up from my ISP and was not doing any special configuration myself.
Note2: I had no problem to connect Xiaomi Gateway to my wifi


#6

The lamp only works with 2.4G wifi, make sure you don’t connect it to 5G.
Another thing is your AP name seems to be very complex, we need to do some tests locally.


#7

Hi,
I am using 2.4G.
And yes my ssid is long and meant to “scare” people… Unfortunately I have connected by whole smart ecosystem to this wifi and i am afraid that if i need to change the name of my wifi i need to do whole configuration again from the scratch.


#8

For the issue of stopping at 0% when connecting, Please try the latest iOS Yeelight app 3.1.12.


#9

Hi Nitram,
Same problem over here. My 3 lightbulbs work perfectly. I bought a lightstrip ( color) and faced all the problems that you described. My network recognizes the strip but it stays at 0%.
All the tips from this forum didn’t work. I ask my buddy ( ict specialist> allso has the yeelight colorbulbs) to check the lightstrip at his place, but the same problem. It doesn’t work. ( we tried routersettings, created a hotspot, newest software, ifttt, etc) Really frustrating!
Doesn’t help you much, but I posted this to let you know that you’re not the only one!


#10

Hi All,
I tried again the trick with creating mobile hotspot with the same name as is my home wifi and now it worked.

I have used android phone to create hotspot with the same name and password as my wifi and connected the led strip with my iphone. (note: i was still using the versions of applications mentioned in my original post.)


#12

i tried it with my laptop as i dont have an android. Any suggestions. still getting 0% connection


#13

@AnwarIKe
Sorry? Laptop?


#14

yea. do not have android for mobile hotspot


#15

Please make sure the version of Yeelight app is 3.1.12.


#16

I have the most up to date version. Syncing on app doesnt get past 0%


#18

Could you please send a video of the connection process to me? @AnwarIKe


#19

sure how do i pm you the video. there will be certain credentials i dont want to make public


#20

zhangxin@yeelight.com , please. Thanks. @AnwarIKe


#21

Sent please confirm you have recieved and provide solution.