Yeelight RBG Bulb - Connection Problems


#1

Hi,

I’ve been using one Yeelight RGB Bulb for a couple of months now and was very satisfied.
I tried to connect it to Alexa yesterday and it didn’t worked.

Then I did 2 things which have maybe led to my problem.
I read a comment at the Alexa Skill that you should rename your bulb and change the server to Singapore.

1.) I changed the name of the Yeelight in the Yeelight App from the standard name to “Wohnzimmer” (means “Living Room”).
2.) I changed my server from “China Mainland” to “Singapore” (I’m from Germany).

Now I have the problem that I cannot add the bulb in the Yeelight App anymore.
I have resetted the bulb 10 times now.

  • Turn it off and on 5 times
  • Light is flashing in different colors
  • Light stays white
  • I can see the yeelight wifi in my smartphone and connect to it
  • I cannot see the bulb in the Yeelight App or Mihome App

I have tried everything now but I cannot connect it anymore even if I switch back to “China Mainland”.

One thing I have recognized is that if I turn my WiFi Router off, a second wifi network is opened by the bulb.
One is called “yeelight …” and the second is called “Wohnzimmer.b” like the name I switched the bulb to.

If I switch ma WiFi Router on again the second WiFi Network “Wohnzimmer.b” disappears after a few seconds.

So the reset of the bulb maybe didn’t reset ALL of the settings?

I hope someone can help me.


#2

Could you try to setup your phone as hotspot and connect the bulb and see if it can be connected. Or do you have Wechat or Whatsapp, let’s do some live debugging.


#3

You mean you could not see bulb network and your WIFI Router at the same time? Quite not follow what’s the meaning of “did not reset all of the settings”?


#4

Sorry if my explanation was misleading.

After the reset I can see the WiFi of the bulb and can connect to it.
I can see my WiFi Router at the same time.

If I shut my WiFi Router off the bulb opens a second WiFi which has the name I changed the name of the bulb to.
So it looks like the reset of the bulb didn’t reset all of the settings to factory default.


#5

I have Whatsapp. What would be the best time for you?
Maybe you can write me some suggested dates/times via personal message?

Thank you in advance.


#6

I got a new mobile phone today.

Much to my surprise it found my bulb directly after I installed the Yeelight App and resetted the bulb again.
So maybe a strange problem with my old Samsung Galaxy S6 Edge.
New mobile phone is a Huawei Mate 9.

Thread can be closed.
If anyone got the same problem as me: try another mobile phone.

P.S.: Alexa is working now as well :grin:


#7

Glad to hear it works for you.

It seems that you have already connected the bulb to Singapore server, so could you help check if you can see the bulb with your Samsung Galaxy S6 Edge with Yeelight application again?


#8

It is a company phone so I had to give it back already.

On the Samsung Galaxy S6 Edge I tried to reinstall the app but without any luck.
The S6 Edge was running Android 7.0.

After reinstalling the app there was a dialog to confirm the needed permissions for searching devices via WiFi.
Maybe there was something messed up with the permissions.

I don’t have any other explanation.

Thanks for your help!