Yeelight not showing up on Google Home after being “linked”


Today my Mijia Desk Lamp stopped responding to google home command. Been trying to reconnect to google home many times but still doesn’t work.
ID: 1763152179
Server: Singapore
App: Mi Home because I cannot connect the lamp via Yeelight app

Please help

1 Like

There’s something error with the cloud server, we have fixed the issue. Please have a try.

Sorry about the issue.

Me too facing same prob

@iamnotintheuk @Dannyosc

Any update? Do you still have the issue?

I have the same issue since the beginning. Also in Singapore, I never managed to connect it to Google home. Same fact, after linking yeelight actions in Google assistant nothing appears in the list

Please provider your mi account, we will take a look.

Hi thank you! My account is 4le91 number 1554103326

I didn’t find your WiFi light, could you paste a screenshot about device list?

I guess this is the problem. I have no way to connect the lamp to WiFi. Can you tell me what to do?

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

Hi! Thank you. Let me try this evening when I go back home. But I’m 100% sure there is not WiFi ap yeelight in my environment. So something is wrong with the lamp. Turn on and off five times should do the trick,| no scene button pressed?

I am also having trouble connecting to my Desk Lamp using my Google Home. A couple days ago it stopped working with the Yeelight Actions service so I switched to the Mi Home service to control it. It worked for a couple days and now today both Yeelight Actions and Mi Home are unable to connect to the lamp.

Hi all!

I’m also having this issue: “account is now linked” message when adding Yeelight service, but next screen is not showing anything about Yeelight or Yeelight service either. Yeelight service looks like it didn’t really complete the Linking Process.
I have TP-Link and Philips Hue services linked in Google Home with no issues.

What can I do?

Thanks in advance.

PS: yeelight light and bulb is working as expected and I can control it from the Yeelight app. Also the same process with Amazon Alexa work es perfectly. My only issue is with Google Home when adding Yeelight to it.


Hi all!

I’m having the same problem. I’m not ablo to connect google home with yeelight or Mi Home. I’m conected to China server because is the only one that allow me to see my Yeelight Bulbs on both apps.

My ID is 1761594576.


Sorry. Yeelight ID is 1541618120

same issue here :frowning:



What happened ? Could you record a video for me ?



Please HELP

My Milight BULB doesn’t work with google Home even if it says “account successfully Linked and added”

Here’s my Mi ID 6175243086

It stopped working for almost 2 years now look I don’t know what to do I’ve reseted my lights but still not working with google Home


please help, Yeelight linked but not on Google home.
how do i change server

mi account: 1624179552