Yeelight LED Colour can't connect to server


#1

Trying to setup new yeelight bulb for few hours, but with no success.
Apple Airport Express set up from 5GHz to 2,4GHz. Bulb connecting to Wi-Fi - ok. Then at 100% couldn’t connect to server. What server by the way?

My location Moscow, Russia.


#2

Could you find the bulb in router’s client list? Can you ping it and check if it’s reachable. If it’s ok, please try to ping “ot.io.mi.com” and see if the cloud sever is reachable. If it is also ok, try to setup your phone as hotspot and connect the bulb. If that’s fine, upgrade your firmware and use your router to connect again.


#3

Unclear. As far as I understand, each bulb creates it’s own Wi-Fi. But, yes, my ZTE router shows this:
f0:b4:29:b7:b3:54 192.168.1.19 74271 yeelink-light-color1_miio45997561 LAN1
f0:b4:29:b7:9c:4a 192.168.1.18 74621 yeelink-light-color1_miio45991663 LAN1
f0:b4:29:b7:b3:32 192.168.1.16 75497 yeelink-light-color1_miio45997527 LAN1
f0:b4:29:b7:92:33 192.168.1.17 76346 yeelink-light-color1_miio45989080 LAN1
f0:b4:29:b7:bb:bf 192.168.1.20 76588 yeelink-light-color1_miio45999716 LAN1
ZTE router keeps connection to ISP, Apple Airport Express create Wi-Fi and work as bridge.

PING ot.io.mi.com (58.83.200.7): 56 data bytes
64 bytes from 58.83.200.7: icmp_seq=0 ttl=37 time=317.686 ms
64 bytes from 58.83.200.7: icmp_seq=1 ttl=37 time=336.744 ms
64 bytes from 58.83.200.7: icmp_seq=2 ttl=37 time=348.381 ms
64 bytes from 58.83.200.7: icmp_seq=3 ttl=37 time=352.430 ms
64 bytes from 58.83.200.7: icmp_seq=4 ttl=37 time=406.241 ms
64 bytes from 58.83.200.7: icmp_seq=5 ttl=37 time=316.118 ms
64 bytes from 58.83.200.7: icmp_seq=6 ttl=37 time=333.088 ms
64 bytes from 58.83.200.7: icmp_seq=7 ttl=37 time=331.105 ms
64 bytes from 58.83.200.7: icmp_seq=8 ttl=37 time=323.095 ms
64 bytes from 58.83.200.7: icmp_seq=9 ttl=37 time=319.734 ms
Request timeout for icmp_seq 10
64 bytes from 58.83.200.7: icmp_seq=11 ttl=37 time=317.985 ms
64 bytes from 58.83.200.7: icmp_seq=12 ttl=37 time=333.836 ms
64 bytes from 58.83.200.7: icmp_seq=13 ttl=37 time=323.927 ms
64 bytes from 58.83.200.7: icmp_seq=14 ttl=37 time=326.368 ms
^C
ot.io.mi.com ping statistics —
15 packets transmitted, 14 packets received, 6.7% packet loss
round-trip min/avg/max/stddev = 316.118/334.767/406.241/22.517 ms

I tried my iphone as hotspot. Yeelight connects ti iphone perfectly, but asks Wi-Fi password. I don’t know password.
What should I do?


#4

Could you bypass your Airport Express and connect the bulb to ZTE router directly? You should reset the bulb firstly and then use our App to connect.


#5

I’m having the same issue. My bulb was working fine with the router provided by my previous ISP but recently I had to change my ISP to a new one that uses the ZTE f660 fiber router and now I cant connect the bulb. Once I select the bulb from the Wifi list in settings (in my iPhone) and go back to the Yeelight app, the progress is frozen at 25% for a while and then it says cannot connect to server. I can still ping ot.io.mi.com but I notice that not all ping messages are successful. However, this was the same with my previous ISP as well so I dont think that’s the issue. I was trying to use the personal hotspot approach mentioned in this thread but I’m not entirely sure how that works. Do I need to forget all other wifi connections in my iPhone before I enable personal hotspot? When I do that, it automatically connects to the bulb though. Can you please give me step by step instruction on how to do this? I have a feeling there is some network setting that needs to be done on the router to get this working because all stopped after I changed the router and it still works fine with the old router from my previous ISP. Do you know what the minimum required network settings on the router for the bulb to work? It is really frustrating that I can’t use the bulb. I’ve already ordered another 3 bulbs and a Mi Wifi Gateway. I want to make sure I figure this out so that I can start using all these devices once they come. I really appreciate your help here.


#6

Do you have Wechat or Whatsapp account? I can assist you do some live debugging.


#7

I’m on WhatsApp. You can use the number +94773962010. I really appreciate your support on this.


#8

[SOLVED] - Thanks Wilson from Yeelight support for helping me to overcome this issue. The issue was with the DNS settings in my router. I’m using a ZTE F660 router and I had to set the following DNS server settings in both LAN and DNS Service settings in my router. Once these are set, try adding the bulbs again and it works.

You should also set the same at the DNS Service level settings as well:


#9

Hi guys, I’m having the same problem and I don’t know what to do. I bought 3 different things: strips, white bulb and coloured bulb.
Firstly I’ve synced the strips, and everything went fine immediately. When I tried to sync the bulbs, nothing happened. I changed location from Singapore to China, I restarted them, I tried to connect the phone straight to the bulbs wifi…But when I try to pair the bulbs with the yeelight app, time’s over and I cannot connect. I’m very stressed and I don’t know what to do. Any suggestions?


#10

Why connect to bulb’s WiFi? Just follow the instruction of the App and do the connect. If it failed, please go to your router’s management portal to check if the bulb is present in your DHCP list.


#11

I did that because I founded lot’s of things to try in order to set the bulbs, but not even one of them worked. Lucky I founded out that these bulbs cannot use the wifi 5 GHz but only 2.4 GHz, so I deactivated the 5 GHz and everything worked!


#12

hey can you help me out with the router settings. I have the same issue.


#13

WeiWei, possible to troubleshoot over whatup?


#14

Please describe your issue firstly, so we can get a basic idea about the issue.


#15

Could you help me? When I try to connect the bulb it stop with the message “connection time out” or something, I’m getting a little bit frustrated.


#16

Could you find the bulb in router’s client list? Can you ping it and check if it’s reachable. If it’s ok, please try to ping “ot.io.mi.com” and see if the cloud sever is reachable. If it is also ok, try to setup your phone as hotspot and connect the bulb. If that’s fine, upgrade your firmware and use your router to connect again.


#17

I can’t acces to ot.io.mi.com, what’s the problem?


#18

I have some problem with you, and i tried to make my setting same with your pic. But, nothing happened. My Yeelight still error. The error msg said “Iphone can’t connect to server”.

Always stuck at 25% and then the error msg appear. I think the problem was on my DNS setting same with yours.
I hope weiwei as Yeelight Staff can help me, or anybody can help me with this problem?


#20

used to work previously. got a new ZTE optical fibre connection. refuses to connect. 99% , brings hope up and then fails to connect. interesting post above with changing of DNS setting. will tinker a bit and get back to the success / failure of the procedure!


#21

Please check if the bulb shows in your router’s DHCP list when the connection failed.