Yeelight LED Bulb RGB v2 doesn't connect to Yeelight app (iOS)


#1

Hello, I recently bought a yeelight but I can’t connect it. I was able to connect it once but the bulb was disconnected immediately.
I followed the instructions on Yeelight app but the connection failed at 25% or there is directly a message “connection failed, verify your information”.
I’ve reset the bulb many times and tried again, but it doesn’t work. I am using the Yeelight app on iPhone with the latest iOS version.
I have a 2.4ghz wifi network and I disabled the 5ghz wifi network. I tested on all servers in the app, but nothing work although the ping test is OK on all servers (sg.ot.io.mi.comot.io.mi.comus.ot.io.mi.com, de.ot.io.mi.com)
I turn ON my hotspot to connect on it but same result.

I don’t know what to do.


#2

Which bulb do you have, Version I or Version II? What voltage do you use, does it match the bulb?


#3

Hello, I have the smart LED bulb (Color) V2 (YLDP06YL).
The voltage used is the french standard, 230v at 50hz, I think it’s OK because of the bulb lights up normally.


#4

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp by power on and off fives times in a row, and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

And at last please use another phone to setup a hotspots with 4G network and try connect the bulb to it, I want to make sure if the bulb is ok. Thanks!


#5

I followed the steps listed but nothing worked. I made many reset of the bulb but initialy I didn’t have problems with the AP in my phone’s wifi list.
The problems is from the step 2 where Yeelight app can’t connect the lamp when I choose them in the wifi list. My wifi password has no special character (only upper case letters & numbers) and there is no special character for password configured in Yeelight.
When I launch the connection, it’s still stuck at 25%. While charging at 25%, the bulb appears in DHCP list with no IP dedicated and it disappears when the message “Connection Failed” appears.
I made test with another phone connected on my router and same settings but I have the same result.
I made cross tests with 2 phones setup as 4G network hotspots but the bulb doesn’t connect.

All the test I made failed.


#6

I got no idea about the issue, it seems there’s some network issue when the bulb try to connect to the cloud.

Which country do you live?


#7

I’m from France. I tested on all servers and the connection failed but when I made a ping test on each server, all the tests succeded. It seems there is no domain blocking of my ISP…


#8

Any solutions ?
i have the same problem from France too !!
Provider : Freebox and you ?
tried 4G Hotspot on B&you.