Yeelight JIAOYUE 650 - no power at all


#1

Hi,

I ordered this lamp from Gearbest and installed it with no issues, however when I try to turn on the electricity nothing happens,

It’s just dead as if no power is going through it. I know that my connection is OK because any other lamp that I plug will work just fine.

What do you guys think? Faulty hardware? Can I be doing something wrong?

Thanks


#2

There will be connection issue if the chassis was screwed too tightly, which could cause distortion of the chassis.


#3

Hi,

I tried to plug it having the chassis completely unscrewed and still nothing. No power, no reaction, nothing.

Anything I can try? I really do not wish to ship it back to China and want to do anything possible to fix it on my own.

Thanks!


#4

Try to contact your retailer to get replacement.


#5

This is already the second Yeelight 650 that they have shipped to me with the same problem. Is this a known issue, or am I just very unlucky?


#6

Damn, reading the threads with 650 problems I am extremely lucky to have got mine OK and in one piece… They must make better packaging for it, can’t believe they don’t have good quality control after manufacturing


#7

I can’t believe you could get two faulty lamp in a row. Please double check the chassis and the power cable.

Someone else in this forum has tried followings to nail down the root cause.


#8

Hi,

Just an update - this actually worked! We plugged the lamp directly to the power and it worked fine!

So the problem itself was on chassis part as the power was not going through to the lamp.

After identifying that, we were able to open the chassis (where the wires originally connect) and fixed the connections.

All working now - thank you guys for the tip and for your responsiveness… hopefully this will help someone experiencing the same issue!


#9

So, what’s the problem? Cable not connected correctly? Or something wrong with the chassis itself?