YeeLight connection timed out


#1

Hello,
I just received my YeeLight and I am trying to connect it to my wifi and phone.
My phone is LG G4 running Android 6.0
I tried connecting with both MiHome app and Yeelight app, on both I am getting the connection timed out message.
I’ve followed the instructions and searched the net for common issues such as these:

I’ve verified that my WiFi settings are ok, I tried resetting the bulb (5 times on and off) but I am still getting that “connection timed out” message every time.

Any other suggestions would be great.
Thanks.


#2

Color Bulb?

What’s the power voltage? If you purchased your bulb from gearbest, it only supports 220v.


#3

Yes, Color bulb as in the tag.
It’s the 220v and my power is 220v as well. Everything should be ok, but still getting that error.


#4

Ok, so it finally worked. I don’t know which of the following made it work but I did two things:

  1. Changed my DNS to Google’s (8.8.8.8) in my routers configuration.
  2. I’ve reinstalled the Yeelight app and chose “China Mainland” as the server (instead of Singapore).

After doing these two I’ve successfully connected using the Yeelight app (and not MiHome).


#5

There might something wrong with your previous DNS server, results in resolution failure of xiaomi domain.


#6

Hello,

I’m having the same problem with my lights. I had them working when I got them. the problem started when I need to add a new one, theregore I believe it might be the firmware since i try to connect on the newer firmwareI at this point…no luck they keep saying ‘timed out’ after 100% sometimes 50%. In any case they won’t show up in DHCP

I have reset the bulbs (they are recognized)
Used different Android devices
Reset my modem
Use DNS

Please assist me with the issue kindly


#7

What’s your router model and phone model?


#8

I have a unbranded connectbox which is a use by Ziggo ISP its limited with settings… phone is a Huawei mate 20 Pro ( 9.0) I used my OnePlus 3T (8.0) too.


#9

Had the same problem with my Huawei p20 pro. I’ve used moto g4 and worked. Someone else wrote that disabling wifi+ on Huawei worked.


#10

Changing router DNS settings to google DNS worked. Thank you so much!