Yeelight claims my WiFi is public

I just purchased a YEELIGHT Lightstrip. I’m trying to connect it to my wifi. When trying to add the light with the Android App and selecting the WiFI network, my network is shown as greyed out, When I select it, the app complains that I cannot use it with Public Wifi.

My network is not public. It is using WPA2 Personal security with a password. It is a Ubiquiti Unifi AC AP Pro. It is set to use WPA2 Only and AES/CCMP Only Encryption.

Is there a reason this is seen as a public network?

Could you help try WPA/WPA2 and some other encryption options? We haven’t seen this issue before, maybe it’s related to some compatibility issue, we need to confirm that.

I tried switching my router to various combinations of Both WPA1 and WPA2, Auto Encryption, TKIP encryption, and AES/CCMP Only Encryption and none of these options worked to make the network show up as a private home network.

Please help to confirm the following two things

  • Make sure your wifi is 2.4G, the device doesn’t support 5G network yet.

  • Could you attach the error screenshot. I didn’t get error message with not use it with public wifi when i select a Public wifi to connect.

BR

Ah, that’s the issue right there. I only have 5G enabled. I’ll re-enable 2.4G.

1 Like

Yeah, that fixed it for me. I didn’t even think about that.

Thanks for the help.