Yeelight Ceiling LED refuses to connect to server


I bought two brand new Yeelight Ceiling light imported to India from China. Both are not connecting to the server. Following is my information:

MI ID: 5150544955
Device : Yeelight Ceiling LED lamp (2018/01)

Steps tried:

  1. Ensured that WIFI is 2.4Ghz
  2. Reduced WIFI security to minimum
  3. Reset ceiling lamp (5 times on off)
  4. Tried with Yeelight and MiHome app on Ios11
  5. Tried with a hotspot (not WIFI router ) and different ISP
  6. Tried China server
  7. Tried Singapore server
  8. The lamp shows as ****_mbdti on the DHCP list as well.
  9. I can ping the io.**** servers from my router
  10. Since none of the connection is working, I cannot update firmware

The best result I got is - after loading to 16%, it just returns to the “Add Device” screen on Yeelight app.

Please help me Yeelight staff!

@coasterli @dingyichen please help if possible !

I posted the information to Xiaomi Cloud yesterday, but they didn’t find any useful info.

As you can see the lamp in your DHCP list, I think the lamp is connected to your router. There must be something wrong when the lamp tried to communicate with the cloud. So could you show me the ping result of “”、 “”、“” and “”?

All the sites are pinging successfully from the router. It does not seem to be connection to server issue. It looks like something is going wrong during the registration. Do you need the lamp serial no?

I am surprised because both the ceiling lamps delivered to me are showing the same problem. Thanks @dingyichen

You have tried using another phone to setup a hotspots with 4G network and connect the bulb to it, right? Please have a try again.

Or do you have anything special setting for your router? Or please have check if the lamp is in the blocking list.


i tried the 4G hotspot but it did not work either. router had no special settings or block list.

however, good news is that I got it working. The trick that worked for me was the following:

  1. reset the ceiling lamp
  2. open yeelight app in China Server
  3. choose add device, and choose color bulb (not ceiling led)
  4. follow next step and connect to your lamps own wifi hitspot
  5. now the setup proceeds halfway and gets stuck
  6. reset lamp again and this time add a new device and choose the led ceiling light
  7. setup is done!

I think you have same problem as me, here is solution:

Same issue here, lamp yeelink-light-ceiling1_mibt62455145

Which country do you live? Could you have a try with other server?

If you still have the issue with the server nearest to you, you can have a try with:
1 Setup a hotspot with another phone and connect the lamp to it to see if it works.
2 If yes, try changing DNS of your router to
3 Reset your lamp, connect again.


I’m in Israel, tried connecting to all servers, same issue.
The lamp connected to my WIFI correctly, I can ping it, so hotstop via another phone does not suppose to solve it.
I can ping all your servers except Singapure, which might be just blocked for pings, traceroute reach it.
What is DNS, how will I surf the web with such DNS ?

In the administration page of your router, there’s an option to change DNS, please have a try.

I guess mi server is blocked by your ISP, change DNS to (DNS of google) may resolve the issue.