Yeelight Bulb WHITE not connecting


I have tried everything that I could find over google, but nothing worked.
It’s so frustrating.

I tried:

  • reseting the bulb multiple times
  • Ibluetooth and wlan, wlan of the bulb too
  • to relogin with my mi account
  • Mi Home AND Yeelight App

No chance to get that lamp in my WLAN.

Please help me.

have you ever tried to change the server to Singapore?

Oh yes, sorry. I forgot that point.
Of coursed I tried with Mainland China ANd Singapore. Same error.

Could you try to use another phone as a hotspot, and then connect the bulb to your mobile network. If it can be connected successfully, it means there should be something with the network or the route.

Tried without success. Same error Message.

Could you find the AP started by the bulb? After connection failed, could you see your bulb on the DHCP list?

Yes, I can see the AP started by the bulb. And yes, I can see it in my list. The Bulb already got an IP from my DHCP server.

Next step?

Can you help me pls?

Please ping and to see if these are reachable

Both are reachable, yes.

Can you tell me a checklist of which attributes or configuration my WiFi has to accomplish to be able to work with the bulbs?

If the bulb has connected to the router successfully and you can access our cloud, the I can’t tell why you are not able to see it in your device list.
Maybe try another phone?? You can also post some screen shot here, so we can take a look.

I can see it in the device list in your app. Then I touch it and the connection assistant starts. Reaching 100% it gives me the error: connection timeout. But I can see it in my DHCP-list on the router (as an offline device of course).

I already tried it with another smartphone in my LAN, didn’t work.
And I already tried it in another house, with another WLAN - there it is working without any problem, with MY phone. So it has to be an issue with my router configuration.

Any thoughts?

I am having a similar issue.
I was able to successfully connect the lights the first time. I had to change my wifi settings, and after that i cant seem to connect it anymore. Trying since 2 hours but not successful. Can you please help?

Could you set your router’s DNS server to

Hi guys,

I`m having the same problem, but I use two routers… the second one, which is in my room I just disabled the DHCP… so should I need to include the IP of the bulb and the mac adress in the adress reservation option? What is happening? and how can I find the IP and the MAC adress of the bulb?

The bulb only supports dynamic IP allocation, if you disable DHCP, it won’t connect.

not even I include the IP and MAC adress in the reservation option?

it not… so, what if I try to connect the bulb to my first router in my living room? the first router have the DHCP working properly…

You can connect your bulb to the first router, it should be working fine.