Yeelight Bulb IP Adress


#1

Can you please add an option to the yeelight app to set static ip adress for each bulb please because my router doesnt have that option and it will be really helpfull?


#2

Do you mean your router doesn’t support DHCP??


#3

It supports DHCP but it doesnt support DHCP reservation so the ip adresses of the bulb constantly change when rebooting the router and i have to look them up every time. Thats why i want an option to set static ip adresses so it doesnt change


#4

Why do you need to know the IP address of the bulb? Did you do some programming? If yes, there is a discovery mechanism you can use.


#5

I use Home Assistant on my computer to control them and you have to manual enter the ip adress for each bulb evry time it changes


#6

Please logon to your router and see if there is an option called “dhcp lease time”. You can set that value to a very large number.


#7

It has that option and it was default to forever but as it didnt work i changed it now to 2 weeks which is the largest and i will see if it works


#8

Hopefully it will work. Also, you can ask Home Assistant team to improve the plugin to support dynamic device discovery.


#9

You’re not helpful like this.
Setting DHCP lease time to high is not a definitive solution.
If you know that there’s a way to set static IP with “discovery mechanism”, you should be able to help him.
Supporting dynamic IPs is not simpler than implementing a plugin that set static IPs.
Why should Home Assistant create a plugin and not you?

Anyway you can set static IP by MAC address reservation that is different for each router.


#10

Exactly, this is more a router issue than client (Yeelight app) issue. You need to make static adress on your router (or sometimes they call it “reservation” of adress).


#11

No, please if you don’t know anything don’t talk.
The majority of devices have the option to set static ip FROM the device. Yeelights can’t.
With different routers the situation is the same, so please don’t talk.


#12

That depends what kind of device. I didn’t see MAJORITY of devices like smart bulb can be set with static ip.


#13

Sorry for not knowing anything, I am just 30 years network administrator that really doesn’t know anything… IP adresses are given by DHCP/DNS server, which is your router. Period. Buy a proper router.


#14

In fact I didn’t say the majority of smart bulbs, I said the majority of device.


#15

Then you should know that you can set static IPs directly from your PC, tablet and smartphone. And that is more user-friendly. Same thing for lots of printers, game consoles and wireless devices.
Anyway you said: [quote=“dalanik, post:10, topic:742”]
this is more a router issue than client
[/quote]
He didn’t tell his router model and it was clear that the guy didn’t know anything about IP reservation.

I was angry because the first staff guy didn’t try to help but he just said:


#16

What? I don’t know where your anger come from… I was just trying to help him. I already suggested him do IP reservation on router because our device (a bulb, a bulb) can’t support static IP allocation (did you expect we could provide a web portal and let user enter IP address???). The bulb already supports a SSDP-like protocol, any decent gateway should be able to find it easily through UDP multicast, it only costs a developer ten minutes to do that. I just don’t understand why Home Assistant plugin doesn’t support that.


#17

I’m using “Address Reservation” and works perfectly here.