Yeelight app doesn't create the Homescreen Shortcuts

Hi, devs! First of all thanks for the great products and the app!

My issue is that the app doesn’t create any Homescreen Shortcuts. I used several launchers but it’s all the same - whenever I try to add any Homescreen Shortcut it just nothing happens. As I haven’t seen reports about the issue it might be something to do with Android version I use - Oreo 8.0.0.

Please see my setup below:
Smartphone: Google Pixel
OS: Android 8.0.0
Yeelight app v3.0.03

Could you please check it and advise on the issue?


@weiwei any comments/suggestions on that matter? Can we please check it out somehow?

Did you check the app rights? the one to make a shortcut?
Otherwise might be Oreo related, have no experience there…

There are no app rights for making shortcuts.

My answer was a MIUI based hint, never mind …

For MIUI devices, there’s actually an item of permission to create homeScreen. In your case, we will have a look at it.

Got it, thanks. Please let me know if you need any additional information.

Hi! Still no news? Did anyone find a way to get the Shortcuts on Oreo? Thanks

Smartphone: Google Nexus 5X
OS: Android 8.1.0
Yeelight app v3.1.00

Yeah, no news at all on that issue, which is strange.

@dingyichen is it even in plans? It’s pretty fat bug for the new devices, isn’t it?

I have nexus 5 in hand. Will look into it right now.

It works with Nexus 5.

Could you please try to check the detail permission list?

The issue is showing yourself starting from Android Oreo only (8.0 and 8.1). The Shortcuts work just fine on every prior Android versions. Is your Nexus 5 on Android Oreo (which is definitely possible only on custom ROMs)?

There are several posts here and there on this forum which confirm that the Homescreen Shortcuts don’t work on Android Oreo.

Got your point. Hold on

Check this out!

in my case it doesn’t work… I tried several times

As I can see, this solution is ONLY for icons that added to home screen by Play Store after every new app installation and it has nothing to do with the issue we are discussing here.

Yes, you are right. Seems google update shortcut installation related interface.

It’s nice you’ve figured out the reason! Can we hope for the quick fix in the future updates?

I am not sure. Actually, that thread didn’t come out a resolution.

To get around this, can you add Oreo’s new shortcuts system directly to the app? Is it possible?