Yeelight app cannot find ceiling light


#1

Hello, I’m trying to connect Yeelight ceiling light to the Yeelight.app (latest ios, Mainland China server). I can see its wifi network on my phone, it’s a strong signal. But the app won’t find it. I’ve tried resetting the lamp several times and with the app installed on two different devices. This is what I keep getting:

It works fine with the remote control. Any help would be greatly appreciated.


#2

Make sure to keep bluetooth on while scanning and the device have been reset.
Additionally, what’s the device ap name, and which entrance did you selecte when adding the new device?


#3

Thanks for your reply. Bluetooth was on while scanning. The name of the app is yeelight. I’m not sure what entrance is. I selected Mainland China server, if that’s what you mean.


#4

Hello, I really need help here. I’ve tried using the Feedback function of the Yeelight app but got no reply at all.


#5

Could you have Android phone, you can have a try with it.


#6

Thanks for the suggestion but I don’t have an Android phone, I’m afraid. I have an iPhone and an iPad. I was under the impression that the lamp should work with the ios version of the app. Does it not?


#7

Yes, of course. If you can connect the lamp to an Android, you can also get the lamp with the same account within your Iphone, I just want you to have a try. So could you see an AP named like “yelink-light-ceiling**” in your wifi list after you reset the lamp?


#8

I can see an AP named yeelink-light-ceiling1_mibta861 on the wifi list. I assume that’s the one. I can try to get hold of an Android phone and see if it helps.


#9

Hello,

Thought I’d let everyone having the same problem know that it’s been solved. I just had to delete the app on my iPhone and install it again. Everything works perfectly now. Thanks for all your help.


#10

Technically, I don’t think reinstalling is helpful for this issue. So is there something other change?


#11

As far I know, there was no other change. When first installed, the app stubbornly refused to find the lamp no matter what I did. I then deleted it, reinstalled it and now it works like magic.

I deleted the app because I was going to install it on an Android phone and didn’t want any interference. The Android turned out to be too old to install anything on it but when I reinstalled the app on the iPhone, it just found the lamp as if there had never been any problem.