Wake up gently by using Yeelight sunrise [IFTTT ISSUE]


#1

Hi, I’m trying to set this applet on IFTTT but I have an issue.
On the last select (Which color?) I can’t select anything because there is only “Options unavailable”.
How can I solve this?


#2

It maybe a problem with the way you linked your Xiaomi account with IFTTT. Disconnect your account from IFTTT and try again. If the issue continues, contact IFTTT or Yeelight.


#3

Same here. Have you solved?


#4

No. It doesn’t work.


#5

Could you try to use “Set brightness” or “Change color temperature” , is their last select occured “Options unavailable”?
In my side, it works well.


#6

In change colour temperature there is the same problem.


#7

No other options available.
I’ve “solved” creating a scene with sunrise and creating a custom applet.


#8

ok


#9

You can operate what angelocala had did.


#10

Scene does not provide a solution for me. Scenes are predefined. I want to set an IFTTT action that takes a number and sets the color temp to that number.

The following actions work:

  • Toggle lights on/off
  • Set Brightness
  • Set scene

The following actions do not work:

  • Change color temperature
  • Change brightness

I also cannot use most of the applets at https://ifttt.com/yeelight

I have 2 E-Y06-A5-201 “Smart LED Bulb - Tunable White”.


#12

1.“Smart LED Bulb - Tunable White” does’t support “Change color” action and “Color mode scenes”.
2.As you said,when you set the “Change color temperature” and “Change brightness” actions,what did they happended?Did the “Which lights” or “Which color temperature” or “Which brightness” failed to load options,?For example they told you “No options found” or “Options unavailable”?Or you can give me the more detail.


#13
  1. I know. I didn’t try “change color” or “color mode scene”; I wouldn’t expect those to work.

  2. When I choose “Change Color Temp” I see the same as angelocala94. “Which lights?” loads and I can select a light. “Which color temperature?” shows “Options unavailable”. The same thing happens when I choose “Choose a brightness”. “Which lights?” works but “which brightness?” does not.


I would like to set color temperature the way I can with “Set Brightness”:


#14

Did you pick “color temperature” as favorites by Yeelight APP?The “Which color temperature” options will load your “color temperature” favorites which you picked on Yeelight APP.


#15

This issue is ruining the Yeelight experience for me.
I simply can’t find any mainstream automation tool that woks. IFTTT is usually the first choice but most actions are unable to be performed due to this “OPTIONS UNAVAILABLE” issue. I tried all you sugested @sheldon but nothing solves it.


#16

I use Tasker to accomplish the gentle wake-up. It’s way more advanced (also complicated) than IFTTT, but integrates with almost everything. And if it doesn’t, then there most certainly is a tasker plugin doing the job.


#17

Could you reconnect your IFTTT account and reconnect Yeelight connection?Sometimes, it will load failed,and IFTTT cached the failed result.


#18

connecting was never an issue, but yes, I disconnected and reconnected it.
I can fill the applet up to the last field, which is COLOR and it has no options available, no matter what I do.
most Yeelight IFTTT applets are plagued by this issue, only very simple stuff remains usable @sheldon