Unable to update Firmware

Yeelight Color (US version)

Current Firmware: 1.3.1
Unable to update to 1.4.2
Server: Mainland China
Connected to Wifi 2.4Ghz, full strength

When I start the update process, progress jumps from 1% to 100% and then fails. How do I update the firmware?

Try to reset your bulb by turning it on and off 5-7 times in a row ,then readd your bulb and then try to update firmware .Hope this helps!

I’ve attempted that. No luck.

Tried USA, SIgapore, and China server

You can try to use hotspots for firmware upgrades, I just tried my color bulb, the firmware was updated from v1.3.1_37 to v1.4.2_0062 successfully, it could be a network problem.


Yes, it seems network issue.

I have problem that I click on update but for few minutes there is 0% and “updating” and then back to page where it was - “Actual version 1.4.2:…” - “Newest version 2.0.6_…” - “UPDATE”. So, I click on UPDATE, 0% and back there. Not working. :frowning: Europe.

I’m in France, so Europe server, and I can’t update any firmware of my 10 yeelight bulb color 1S. When I click update , it seems to load for a second and then the update button came back. I click again, same thing.

From 1.3.2-0018 to 2.0.6-0024.

I want to update because they keep randomly disconnect briefly.

Any help would be greatly appreciate. Thanks.

Do not make an update of your yeelight bulbs color 1S to 2.0.6-0024 firmware. It’s faulty. The bulbs will be unusable after update.
I’ve made an update to 2.0.6-0024 firmware. After that my 1s bulb went offline and I have no possibility to connect it again. Full reset and reconnect doesn’t work. See my topic.

I’m experiencing the same as thomasj (just using China, because Meteorite aka Crystal Pendant works with it…), what do you suggest then?

I managed to update both my bulbs from firmware 0024 to 0034. I was getting the same error as everyone else, but I found a way to get around it. Here’s how:
There seems to be a random delay between the app and the bulb itself. Sometimes it takes up to 5 seconds to change color, other times it’s instantaneous. Switch the bulb on and off, close and open the app, until you find a moment when the sync between the app and the bulb is very short. That’s when you need to try to update and it will work.